WordPress.org

Ready to get started?Download WordPress

Forums

The uploaded file could not be moved to . (27 posts)

  1. dayabay
    Member
    Posted 8 years ago #

    I recently updgraded from 2.0 to the new 2.0.1 and somehow I must have done something to get this error message when I try to upload a picture:

    The uploaded file could not be moved to .

    Can someone let me know what its referencing and what/where I need to fix?

    Thanks so much
    Zach

  2. ronniec
    Member
    Posted 8 years ago #

    I also have the same problem on 2.0.1. It sounds liks it's being uploaded to a temp directory but then can't be moved from there - perhaps it's a security feature of the server? (I'm on Apache.)

  3. bob58
    Member
    Posted 8 years ago #

    Can you have a look at your fileupload_dir entry in the admin panel ? (options -> misc)
    Is that set properly ?

  4. ronniec
    Member
    Posted 8 years ago #

    Well, it began working just after you posted. I can now upload okay - except the "delete" function doesn't work. I think it might be the permissions set on the uploaded files? - apache owns them whereas I own the rest of the files in the WP directory.

  5. Kalebeul
    Member
    Posted 8 years ago #

    Getting the same with 2.0.1. File upload directory is wp-content/uploads with permissions 777. Doesn't make any difference whether the box dividing uploads into years and months is checked.

  6. mikkelrj
    Member
    Posted 8 years ago #

    I also experience the mentioned upload problem. However, I think it worked fine before moving the location of my wordpress installation to a sub directory; the url changed from mrj.woo.dk to mrj.woo.dk/squareroot. What could have gone wrong?

  7. mikkelrj
    Member
    Posted 8 years ago #

    How odd, I was certain I had set write-permission on the uploads-folder, but found that I hadn't. After setting write-permission on the wp-content/uploads folder it works fine.

  8. lemuelj
    Member
    Posted 8 years ago #

    I got past my uploaded file could not be moved error by going into server via ssh, and noticed that the owner of one of the folders in the upload area was set to group and owner as apache instead of the account user. When I changed group and owner on this folder, I could then upload images. So even though I had persmissions set to 777, the group and owner still needed to be correct.

    Lem

  9. www.onlinecasinoselite.com
    Member
    Posted 8 years ago #

    Upon upload I kept getting:
    "The uploaded file could not be moved to ."

    I had just finished migrating WP 2.01 from one server to another. I had wp-content/uploads permissions set correctly as 0777. The fix was:

    (1) I copied my uploads folder (and renamed it)
    (2) I then deleted wp-content/uploads
    (3) I then recreated wp-content/uploads (mkdir)
    (4) I then set permissions on wp-content/uploads (chmod 0777)
    (5) I then copied all the folders/content I copied in step 1 --> the folder created in step 4

    Voila. Works again, I can upload.

  10. austin2k
    Member
    Posted 8 years ago #

    I had no contents directory. I created it. Set it to 0777 and I have the same problem. Running 2.0.2.

    The complete upload error: "The uploaded file could not be moved to ."

    Any more suggestions?

  11. jakebrumby
    Member
    Posted 8 years ago #

    I had the same problem with WP 2.0. I just made the following folders 777 and it now works:

    uploads
    uploads/2006
    uploads/2006/04

    Thanks for your help.

  12. outinthewops
    Member
    Posted 8 years ago #

    Does the wp-contents folder have to be 777 as well? And does the file being uploaded have to have its permissions set to 777?

  13. iamiam
    Member
    Posted 8 years ago #

    I had the same situation (new server, no uploads permitted, same error reported) and followed the [delete] [re-create] [assign permissions] process and it worked fine for me as well.

    I did it slightly more easily than copying and re-naming, though. I opened up File-Zilla, connected to the server that my blog is on, deleted the naughty [uploads] folder completly, re-uploded the folder from my local disk, then drilled down the most recent branches of the tree, setting permissions of 777 as I went.

    Pity it has to open the door so wide to the world though.

  14. maxwell91
    Member
    Posted 7 years ago #

    I have the same problem uploading (The uploaded file could not be moved to) I read the the above post.. i Have wordpress 2.0...Right now i have ws-content/uploads/777 in the section Miscellaneous/options when i also created a folder for uploads and sub dir for 777....though i still get the error when trying to upload...

    anyone can help

  15. yosemite
    Member
    Posted 7 years ago #

    max: If the parent folder is 777 (actual directory where file is being created) and you still get an error, it's likely that the file may already exist there. Check with ftp?

    Another issue is that some configurations require ANOTHER subdirectory for thumbs (such as wp-content/uploads/2006/07/.thumbs). Check that too?

  16. maxwell91
    Member
    Posted 7 years ago #

    Thanks yosemite though i still have problems...maybe i'm not understanding you right..can you give me step by step... I type wp-content/uploads/2006/07/.thumbs Miscellaneous/options section... And i created folders: 2006,07,.thumbs in my FTP. though i got the error

    Unable to create directory /home/nichols/public_html/cashbizonline-com/wp-content/uploads/2006/07/. Is its parent directory writable by the server?

  17. yosemite
    Member
    Posted 7 years ago #

    No need to create directories. What you need to do is simply make sure the existing ones allow for writing.

    Your error (above) leads me to believe the directory /07/ is not set to 777. Confirm.

  18. maxwell91
    Member
    Posted 7 years ago #

    I'm still having problems is there i can email my info maybe you check in admin to see whats wrong?? when your free?

  19. yosemite
    Member
    Posted 7 years ago #

    Actually I would need ftp user/pass to check permissions. You can eamil me from my site...

  20. uhu_maotouying
    Member
    Posted 7 years ago #

    hi friends, strange things happen, i am still suffering from the same problem, cannot add pictures to wp ...
    i can see my uploaded *.jpg pictures and thumbnails neatly sitting in /wp-content/uploads/2006/.
    both dirs /wp-content and /uploads have my
    user-id : admin
    user-group : psacln
    permissions : 777
    however the *.jpg pictures come with a strange
    user-id : wwwrun
    user-group : www
    permissions : 755 (pics) or 511 (thumbs)
    i cannot chgrp or chown those files from plesk admin tool.
    i hope this helps ?
    thanks a lot, uhu

  21. uhu_maotouying
    Member
    Posted 7 years ago #

    update : i used the ssh terminal to add the
    usergroup : www
    user : wwwrun
    now i can post and post
    cheers, uhu

  22. RosiG
    Member
    Posted 7 years ago #

    I wanted to say that using FileZilla, copying the uploads folder to my desktop, deleting the current folder from the server, reuploading the folder from my desktop to the server, then changing all permissions to 777 worked for me!!!

  23. frotzed
    Member
    Posted 7 years ago #

    Also had the "The uploaded file could not be moved to ." error and found that the only fix was to download the entire uploads dir, delete the uploads dir on my server, create a new uploads dir, CHMOD it to 777, upload the files back to the uploads dir.

    It's exactly as josepo said in his response.

  24. tiny3d
    Member
    Posted 7 years ago #

    There is one possible reason for this error that has not been discussed here. And that is if PHP is configured to run in SAFE MODE.

    When PHP runs in SAFE MODE it is blocks all attempts for php scripts to access files that are owned by another user than the executing script.

    To allow the uploads there are two possibilities:

    1. Set safe_mode = Off in php.ini (this will severly lower the security level of your php installation).

    2. Set safe_mode_gid=On in php.ini
    setup the upload directory with sticky bits: chmod 7777 wp-content/uploads
    If you're using the year/month setup set the sticky bits on the year-folders aswell. Make sure that the group on all the folders is the same as the owner of the php-scripts (normally the user account).

    Hope this helps...

  25. arjeneeken
    Member
    Posted 7 years ago #

    Josepo, thanks for your post. I just did the same and it worked!

  26. bt62190
    Member
    Posted 7 years ago #

    I guess this would work fine on a linux based server, but what about a windows based server where permissions cannot be changed?

  27. Clicknathan
    Member
    Posted 7 years ago #

    It looks like this issue was resolved.

    I had the same problem and had to actually go down in and set the permissions to every folder down to the month. So to avoid future months folders not being able to be created / written, I went to Options > Miscellaneous in the Admin panel and unticked the checkbox there.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.