WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] The translated pages doens't exist. (19 posts)

  1. linusjosephson-2
    Member
    Posted 1 year ago #

    Hi,

    I'm trying to make Polylang work with a theme I bought (http://themetrust.com/demos/uber/) but with no success.

    If I translate a page it only reads "Page Not Found". If I activate the url prefix in the url (/en/ and /sv/ etc.) all pages reads "Page Not Found".

    What could be wrong?

    You can find the page here: http://artinstockholm.com/sv/

    http://wordpress.org/extend/plugins/polylang/

  2. linusjosephson-2
    Member
    Posted 1 year ago #

    Update - The homepage (a static page) linking seems to works fine now, its only the pages that doesn't show its content. Can't figure it out.

    But everything seems to work when I disable the nice permlinks and use the default form (http://artinstockholm.com/?p=123). Is it any way I could get (http://artinstockholm.com/exempel-inlagg/) to work?

    Any ideas.

  3. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    This is likely one of your plugin of your theme which badly flush rules. See http://wordpress.org/support/topic/404-everywhere-3

  4. linusjosephson-2
    Member
    Posted 1 year ago #

    Hi!

    Thank you for the reply and the suggested solution. I tried comment the line "flush_rewrite_rules( false );" in the theme but with no success.

    Do you have any other idea?

    Thanks!

  5. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Did you resave your permalinks after this?

  6. linusjosephson-2
    Member
    Posted 1 year ago #

    With 'resave your permalinks', do you mean just update the pages after changing the permalinks settings? In that case yes, and unfortunately it didn't make a difference :-(

  7. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I meant: click "save changes" in settings->permalinks.

    Are you using plugins? Could you check with only your theme and Polylang activated?

  8. linusjosephson-2
    Member
    Posted 1 year ago #

    Yes, I have clicked save changes but with no success.

    I don't use any other plugins than polylang.

  9. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Does it work as you would expect if you use a default theme such as twenty twelve?

  10. linusjosephson-2
    Member
    Posted 1 year ago #

    Yes, it works like a charm when I activate the default theme.

  11. elvarano
    Member
    Posted 1 year ago #

    Have you solve this problem?

  12. linusjosephson-2
    Member
    Posted 1 year ago #

    No, I haven't found a solution yet :-(

  13. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry. I did not forget you but I have a long list of other topics waiting on the pile. Clearly there is conflict with the theme. Is it freely downloadable?

  14. linusjosephson-2
    Member
    Posted 1 year ago #

    Chouby: If you are interested I could e-mail you the theme and you could take a closer look?

  15. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Let's try like this. You can contact me here

  16. linusjosephson-2
    Member
    Posted 1 year ago #

    I've sent you a mail containing the files, thank you!

  17. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    OK. I made the test. The bad flush_rewrite_rules( false ); is present two times at line 616 and line 638 in functions.php. I commented these 2 lines, then went back to settings->permalinks, clicked on 'save changes' and my pages are back.

    Please send to the theme author this link: http://codex.wordpress.org/Function_Reference/flush_rewrite_rules#Usage which clearly states that using this function in an 'init' hook is bad practice.

  18. linusjosephson-2
    Member
    Posted 1 year ago #

    Thank you, this works great!

    I will forward your comment.

  19. elvarano
    Member
    Posted 1 year ago #

    Sorry for the absence, I was testing! Yes it works. I tried to search for the flush_rewrite_rules( false ); but I was looking for it only in my child theme ... this is why I'm not a coder. I could save your time, sorry.

    However it works really well. Congratulations, and thanks to develop the best free translation plugin for wp!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic