WordPress.org

Ready to get started?Download WordPress

Forums

Advanced iFrame
[resolved] The sub menu under the iframe with Firefox and IE (13 posts)

  1. Usapuka
    Member
    Posted 9 months ago #

    Hello,
    With Chrome the sub menu are always over the others elements (iframe, slider, content, sidebar, etc.) but with Firefox and IE the sub menu are under the iframe and over the rest ┬┐what can I do?
    Thanks,regards.

    http://wordpress.org/plugins/advanced-iframe/

  2. mdempfle
    Member
    Plugin Author

    Posted 9 months ago #

    Have you tried to give the iframe a z-index?
    And what is in the iframe? videos? flash?
    Because then maybe the wmode=transparent parameter can help.

    Best, Michael

  3. Usapuka
    Member
    Posted 9 months ago #

    Hi Michael,

    Thank you for your answer.

    Yes, I tried a z-index for the menu and the iframe, with the same result, it work fine with Chrome and not with Firefox and IE:
    (I'm using the theme Twenty Twelve with a child theme)

    .main-navigation {
    position: relative;
    z-index: 500;

    I tried your Plugin because I can give a Class name to the iframe, in my case "pluto"
    .pluto {
    position: relative;
    z-index: 0;
    }

    In the iframe I have a Articulate Storyline presentation (I have the same problem with the plugin for Articulate).

    I tried a flash presentation with the same problem.

    Thnank, regards.

  4. mdempfle
    Member
    Plugin Author

    Posted 9 months ago #

    Maybe this helps:
    http://zedomax.com/blog/tech/css-hack-how-to-display-css-dropdown-menus-over-iframes/

    They add the z-index to the ul li elements...

  5. Usapuka
    Member
    Posted 9 months ago #

    Thank you Michael,

    I tried but it doesn't work.

    Regards,

  6. mdempfle
    Member
    Plugin Author

    Posted 9 months ago #

    Do you have an url?

  7. Usapuka
    Member
    Posted 9 months ago #

    Here is my testing site: http://tecnobiz.com.ar/Web2013/
    Under "Necesidades" (were the iframe is)there is a drop down menu. Please compare "Inicio" with "Necesidades".

    Thank you, regards.

  8. mdempfle
    Member
    Plugin Author

    Posted 9 months ago #

    Have you set
    wmode=transparent?

    in your settings it seems to be
    wmode=window

  9. Usapuka
    Member
    Posted 9 months ago #

    I think is in "transparent".
    Please see: http://tecnobiz.com.ar/ftp/Transparency.JPG

    Thank you, regards.

  10. mdempfle
    Member
    Plugin Author

    Posted 9 months ago #

    not there. at the object tag where you include the flash.

    Best, Michael

  11. Usapuka
    Member
    Posted 9 months ago #

    I added it but nothing changed:
    [advanced_iframe securitykey="b8fb79f546e021779e10e0aac5cb6865599b7319" src="http://tecnobiz.com.ar/Web2013/wp-content/uploads/articulate_uploads/Impacto_y_necesidades/story.html" wmode="transparent" width="100%" height="580"]

    Thank you, regards.

  12. mdempfle
    Member
    Plugin Author

    Posted 9 months ago #

    not in the iframe.

    here:
    <object width="100%" height="100%" align="middle" id="player" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=10,0,0,0" classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"><param value="show all" name="scale"><param value="story.swf" name="movie"><param value="best" name="quality"><param value="player" name="name"><param value="true" name="allowFullScreen"><param value="#FFFFFF" name="bgcolor"><param value="vHtmlContainer=true&TinCan=false&vLMSPresent=false&vAOSupport=false" name="flashvars"><param value="transparent" name="wmode"><param value="always" name="AllowScriptAccess"><embed width="100%" height="100%" align="middle" allowscriptaccess="always" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" swliveconnect="true" bgcolor="#FFFFFF" quality="best" scale="show all" flashvars="vHtmlContainer=true&TinCan=false&vLMSPresent=false&vAOSupport=false" src="story.swf" wmode="transparent" allowfullscreen="true" name="player" id="eplayer" tabindex="0"></object>

    The iframe itself is fine. I added some text before where the menu shows o.k. over the iframe.

  13. Usapuka
    Member
    Posted 9 months ago #

    Hi Michael,

    I found out who is causing the problem! I added the following in my Child Theme, in order to make transparent the drop down menus:

    .main-navigation li {
    opacity: 0.90; /* da transparencia */
    }

    Without this, the problem disappears (as you can see). Now I have to find a way to make the submenus transparent avoiding this problem.

    Ouch! Not in IE. Now is Ok in Firefox and Chrome.

    Thank you for your help, regards.

Reply

You must log in to post.

About this Plugin

About this Topic