WordPress.org

Ready to get started?Download WordPress

Forums

WP Maintenance Mode
[resolved] The service is unavailable. (5 posts)

  1. karlos1968
    Member
    Posted 1 year ago #

    With the plugin activated it shows the following message in front page:

    The service is unavailable.

    I think the problem is the server (windows server) because I have the plugin running in another server (linux) and works fine.

    Anybody with the same problem?

    Regards

    http://wordpress.org/extend/plugins/wp-maintenance-mode/

  2. Frank
    Member
    Posted 1 year ago #

    Maybe you have more information; can you active the constant WP_DEBUG in the config-File of WP and see, that you have a hint. I can only test on a local windows system, like XAMPP; but I think is not the same and it works.

  3. PeterLengkeek
    Member
    Posted 1 year ago #

    I have the same kind of error:
    - I have WP Maintenacemode actived
    - Installed a new template. Want to upload a logo into the template.
    - pressed "save options". I get following error message:
    Service Temporarily Unavailable

    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

    - url related: http://<my site>/wp-admin/options.php

  4. Frank
    Member
    Posted 1 year ago #

    But the plugin don't work wiht options.php

  5. Ekleipsis
    Member
    Posted 1 year ago #

    Just had this happen to a client's site today. If you are using a Windows IIS webserver this should do the trick.

    Using IIS 7.x with the MS URL Rewriter installed (http://www.iis.net/downloads/microsoft/url-rewrite)
    And PHP for your site running in FastCGI mode.

    Then you need your web.config file in your site's home directory to contain these details:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <rewrite>
          <rules><rule name="Main Rule" stopProcessing="true"><match url=".*"/><conditions logicalGrouping="MatchAll"><add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true"/><add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true"/></conditions><action type="Rewrite" url="index.php"/></rule>
    				<rule name="wordpress" patternSyntax="Wildcard">
    					<match url="*"/>
    						<conditions>
    							<add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true"/>
    							<add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true"/>
    						</conditions>
    					<action type="Rewrite" url="index.php"/>
    				</rule></rules>
        </rewrite>
    		<httpErrors errorMode="Detailed" />
        </system.webServer>
    </configuration>

    If you are still using IIS6 then a similar solution will work but you would need a Third Pary URL rewriting ISAPI module for the functionality usually given with Apache/ModRewrite in .htaccess

    Hope it Helps

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.