WordPress.org

Ready to get started?Download WordPress

Forums

The "#respond" link on comments in WP 2.0 (3 posts)

  1. citeewurkor
    Member
    Posted 8 years ago #

    Don't know if anyone else noticed this or not, but in the new 2.0 version, if you have a post with no comments, the link to comments will have a "#respond" hooked on the end of it.
    I'm sure I'm not the only one whose theme didn't have the page bookmark "#respond" in the comments template...

    so I added this just before the comment form:
    <a name="respond"></a>
    When people click on the comments link when an article has no comment, they will be sent to the comments form of the article. Before they would just be sent to the post page, since #respond didn't exist before.
    just an fyi, in case someone else runs into this.

  2. MOBINKC
    Member
    Posted 8 years ago #

    I think I'm having a similar problem.

    I'm running WordPress 2.0 at http://mike.mikeandandrea.us alternately http://www.mikeandandrea.us/MikeWordpress

    I'd previously upgraded to WP2.0RC3

    Today in an effort to get comments working, I upgraded to WordPress 2.0 Full Release.

    Basically, I followed the upgrade instructions to a T, renamed my existing installation for backup purposes, put the new installation in place (named the folder what I wanted it to be) moved my wp-config.php file over, and ran the /wp-admin/upgrade.php successfully.

    I still cannot get comments to work.

    I am using the default Kubrick theme.

    I'm attempting to put the anchor tag in as mentioned above, since I think that's what my problem is...

    Where exactly in which file do I need to put that anchor?

    Thanks, any help much appreciated.
    Mike O'Brien

  3. citeewurkor
    Member
    Posted 8 years ago #

    Mobink. I was just pointing out the new link for users of themes that may not have the <a name="respond"></a>
    tags in their comments template. Just a minor change from 1.5 it would seem.

    But to address your issue, it would seem that you wouldn't have to run the upgrade script.
    But I checked your blog and it says you have to be logged in to comment.
    You can change that in your dashboard under Options / Discussion.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags