WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] The requested URL was not found - permalink error (17 posts)

  1. kiwiTaff
    Member
    Posted 9 months ago #

    When I update the permalinks to anything but default, links in the site give the error The requested URL ### was not found on this Server.

    • I have just created a clean install of wordpress 3.6.1.
    • I have checked the links in the dashboard work
    • a hello world post worked and I was able to post comments etc. when the permalinks were set to default
    • .htaccess was created automatically and the time stamp updates each time I saved the permalink settings
    • I am using WAMP version2.4
    • The apache version is 2.4.4
    • I am using localhost
    • I feel I am missing one small detail

  2. wpfan1000
    Member
    Posted 9 months ago #

    Please clarify what you mean by:

    links in the site

    Do you mean links in pages? Bookmarked links? Menu links?

  3. kiwiTaff
    Member
    Posted 9 months ago #

    The links in pages eg - leave a comment, category links and archive links all work if the permalink is set to default, any other setting gives URL not found error.

    I am using the Twenty Thirteen theme.

  4. wpfan1000
    Member
    Posted 9 months ago #

    Well the permalinks need to be regenerated if the slugs are changed.

    See

    http://wpquestions.com/question/show/id/7321

  5. kiwiTaff
    Member
    Posted 9 months ago #

    I don't understand. I have set the permalinks using:

    settings>permalinks>permalink setting>month and name

    then creating the post. There shouldn't be anything to regenerate. Am I missing something?

  6. wpfan1000
    Member
    Posted 9 months ago #

    Well what I think may be happening is this:

    You create a post using name for permalink.

    eg so the URI is yoursite/mypost1

    Now you change to month and name

    so the URI becomes something like yoursite/2012/10/04/mypost1

    I may be wrong as to how the URI is formed, but the point is the URIs to pages and posts change.

    BUT some links on your site still point to the old yoursite/mypost1 but should point to yoursite/2012/10/04/mypost1 and so when you click on that link you get URL ### was not found on this Server..

    So a regeneration updates all URIs so they are correct.

  7. kiwiTaff
    Member
    Posted 9 months ago #

    I deleted all post, with permalinks settings> month and name I created a new post, clicked on update.

    Clicking the view post button gave me a
    Not Found The requested URL /purpleAvo/2013/10/adsfasdf/ was not found on this server. error.

  8. wpfan1000
    Member
    Posted 9 months ago #

    Ok but did you thoroughly read, understand and try the things in the article that I mention above?

  9. kiwiTaff
    Member
    Posted 9 months ago #

    I tried setting the permalinks to default and changing it back.
    I rechecked the .htaccess and the content is

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /purpleAvo/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /purpleAvo/index.php [L]
    </IfModule>
    
    # END WordPress

    I have stopped and started the server and cleared the cache.

  10. kiwiTaff
    Member
    Posted 9 months ago #

    I believe SEO is a plugin. I do not have it installed.

    I used phpmyadmin to check the options table in the database and the permalink setting is being recorded correctly there.

    It still does not work.

  11. kiwiTaff
    Member
    Posted 9 months ago #

    It still does not work

  12. wpfan1000
    Member
    Posted 9 months ago #

    Ok so the other thing is that you may have a cache plugin that is serving up old pages with old links?

    Do you have a cache?

    Has it been cleared?

    I would also deactivate all plugins and use a core theme like twentytwelve and see if that makes a difference.....

  13. kiwiTaff
    Member
    Posted 9 months ago #

    I am using the twenty thirteen plugin and the only plugin is askmet.

    Being a fresh install, it should not be this hard to get pretty permalinks to work.

  14. wpfan1000
    Member
    Posted 9 months ago #

    Sorry, I am not sure what else to try

  15. kiwiTaff
    Member
    Posted 9 months ago #

    Problem was solved the solution being painfully simple.
    Using WAMP I clicked on its icon in the task bar then selected

    apache>apache module before clicking on rewrite_module in the drop down list.

  16. gagan_mathur
    Member
    Posted 3 months ago #

    THANKS A LOT MAN :) :)

  17. tpasaule
    Member
    Posted 2 months ago #

    Many thanks, kiwiTaff

Reply

You must log in to post.

About this Topic