WordPress.org

Ready to get started?Download WordPress

Forums

The requested URL /index.php was not found on this server. (10 posts)

  1. Wigmore
    Member
    Posted 1 year ago #

    HELP!!

    I followed the instructions on how to change my URL so that it does not use the /Wordpress at the end. It didn't work so I changed everything back but now I cannot do anything in WP without this message coming up - I can't even save my general settings so that the WP Address and Site Address both have /Wordpress. When I click on save settings I get the The "requested URL /index.php was not found on this server." message. I'm REALLY worried I've list everything (I do have a copy of WP files on my desktop). I am in FileZilla and everything was put back as it originally was - the index.php file is where it was.

    PLEASE HELP as I cannot now do anything to my site - I cannot get off the general settings page even.

    Suzi

    [No bumping. If it's that urgent, consider hiring someone.]

  2. singhnsk
    Member
    Posted 1 year ago #

    Have you tried defining your site's URL's in the wp-config file? Follow this:
    http://codex.wordpress.org/Changing_The_Site_URL

    If you wanna remove /wordpress, you need to move wordpress out of the /wordpress directory (copy everything to home) and then change the permalinks in options.
    Or else export everything, make a new install of wordpress in the home directory and import everything back in here.

  3. Wigmore
    Member
    Posted 1 year ago #

    Thanks.

    I edited the wp-config file as it said in the instructions. I am now able to get into WP admin, I can open the actual site to the home page, but if I click on any other pages I get the same message I was getting in the first place - that index.php cannot be found. I have to leave work now so I'll have to carry on at home. My original set-up when everything worked was that in FileZilla it showed my public_html folder - within that was the /wordpress folder with all the files in. As far as I was concerned everything was put back to how it originally was so I really don't understand what's gone wrong. Do you know why my pages are now not working? Thanks again
    Suzi

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you re-saved your permalink structure?

  5. singhnsk
    Member
    Posted 1 year ago #

    Just like always, esmi rocks :D

    Just re-save your permalink structure. Wp-Admin> Settings> Permalinks

    If that doesn't work, your install might have gone wrong. Lets talk about that later, only if re-saving permalinks won't work.

  6. peredur
    Member
    Posted 1 year ago #

    Hmm. I've got a variety of this problem.

    I've downloaded my site to my local machine in order to do some work on it offline (trying out a new 'phone-friendly theme and some other changes). It all works fine if I change the permalinks to their default setting, but no joy at all if I change to any of the other permalink settings.

    Any ideas how I can get the other permalink setting to work?

    PAE

  7. peredur
    Member
    Posted 1 year ago #

    Doh! Forget it, and my apologies.

    Permissions!!!! You'd think I'd know by now.

    :(

    PAE

  8. tonydjukic
    Member
    Posted 10 months ago #

    Great fix Esmi.

    My issue was very weird. Home page worked, /wp-admin/ and everything in it worked, but all other front end pages were failing. It happened on a development version (using MAMP) and occurred after I took the dev version live by copying over files, etc.

    It was a redesign for an existing site, so I didn't need to export content or assets; just copy over the new theme I'd developed. When I went back to the development version to start working on the next phase, the problem started.

    Fixed now though; once again the WordPress community saves the day.

  9. cheshireoctopus
    Member
    Posted 8 months ago #

    Using MAMP - ran into similar problem as OP but the issue was with creating new pages.

    Esmi's fix worked for me as well.

  10. berkeley110
    Member
    Posted 6 months ago #

    Had the same problem on a local machine using MAMP. Setting permalinks to Default and back again in wp-admin page did the trick.

    Thanks to Esmi!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags