WordPress.org

Ready to get started?Download WordPress

Forums

Simple Facebook Connect
[resolved] The post's links must direct to the application's connect or canvas URL. (18 posts)

  1. samdekian
    Member
    Posted 1 year ago #

    I receive this massege when i'm traing to publish a new post on Facebook:
    "The post's links must direct to the application's connect or canvas URL."
    Can you help me?

    Thanks

    http://wordpress.org/extend/plugins/simple-facebook-connect/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    Go to the Facebook App. Edit its settings. On the Advanced settings page, disable the "Stream post URL security" option.

  3. mfraham
    Member
    Posted 11 months ago #

    Hi!

    I tried to do this procedure, but I not found this option: Stream post URL security
    Could you help with more details, please?

    Go to the Facebook App. Edit its settings. On the Advanced settings page, disable the Stream post URL security option.

    Thank you!
    Marcos

  4. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 11 months ago #

    Go to https://developers.facebook.com/apps

    On the left hand side, click your app to select it.

    Next to the "Settings" section in the middle column, there's an "Edit Settings" link. Click that.

    On the new page, under the "Settings" menu on the left hand side, click "Advanced".

    Under the "Migrations" section, find "Stream post URL security". Set it to "Disabled".

    Click the "Save Changes" button at the bottom of the screen.

  5. lacike
    Member
    Posted 11 months ago #

    Are there any plans to fix this in near future? Stream post url security is part of July api changes, so this solution is kind of deprecated..

  6. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 11 months ago #

    Stream post URL security is not part of the July API changes listed here:
    https://developers.facebook.com/roadmap/

    Also, it doesn't make any sense for them to deprecate that particular option. What the "Stream post URL security" option does is to make it so that an app cannot post any links that don't link to it's own URL. But many apps do want to post arbitrary links to other sites, so disabling this makes sense for those case.

    The only way this actually affects usage of SFC is if you use a shortlink modifying system with your blog, because SFC uses the shortlink. The default shortlinks in WordPress will have your own URL in them, but if you use Jetpack to get wp.me links, or a bit.ly plugin, or something like that, then you'd want to use the shortlink so that you can get stats information from that service. In that case, because the URL no longer matches the site's URL, you need to have this option disabled. For the default case, it works fine if it's enabled.

  7. lacike
    Member
    Posted 11 months ago #

    Hm, I have a webpage without any url shortener and I am unable to post the blog post to facebook.
    So, I have to disable the security despite the fact that there should be the correct url match.

  8. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 11 months ago #

    Are you using Jetpack? If so, then the wp.me shortener is enabled by default and it's trying to use that.

  9. lacike
    Member
    Posted 11 months ago #

    No Jetpack, only Simple Facebook Connect.

    If my url is:
    http://example.com/webpage/vystava-2013/ (with modrewrite)
    http://example.com/?p=1072 (the actual link)

    in sfcPublish() I see:
    "link": "http:\/\/example.com\/?p=1072"
    "picture": "http:\/\/example.com\/webpage\/\/wp-content\/gallery\/cache\/10_320x240_1_6000.jpg"
    "actions": "[{\"name\":\"Share\",\"link\":\"http:\\\/\\\/www.facebook.com\\\/share.php?u=http%3A%2F%2Fexample.com%2F%3Fp%3D1072\"}]"

    Facebook returns error:
    "The post's links must direct to the application's connect or canvas URL."

  10. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 11 months ago #

    If you're getting that message, then you don't have your applications connect URL set to http://example.com, basically. Or you have a needless "www" prefix, or lack of a needed one. Something to that effect.

  11. CelloG
    Member
    Posted 11 months ago #

    so can I then enable the "July 2013 Breaking Changes" option safely? I have 2 notices I just received an hour ago:

    Gregory Beaver's blog, is currently using the following deprecated features:

    1. Social Plugins (Like Button, Like Box) without absolute URL's in their href parameter.
    2. Non-threaded comments. Please see the developer roadmap for more details about this change.

    Neither of those appears to be true. I use the latest jetpack Version 2.2.5 with wordpress Version 3.5.1

  12. lacike
    Member
    Posted 11 months ago #

    Samuel (Otto),

    I sent you an email with the details of my installation and generated javascript code on webpage.

    Could you, please, check it?

    Thanks!

  13. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 11 months ago #

    @lacike: No. I've already answered your question. Just disable "Stream post URL security". If this answer isn't enough for you, then I suggest that you use a different plugin.

    @CelloG: I've enabled the July 2013 breaking changes option with no side-effects. I believe the Like Box widget may stop working at some point in the future, but for now, it's fine.

  14. mjc308
    Member
    Posted 10 months ago #

    Thank you for this! I was trying to find the advanced bit in the plugin settings, not the facebook app settings, until I found this.

  15. CelloG
    Member
    Posted 10 months ago #

    I enabled July 2013 breaking changes, and now jetpack's publicity to facebook does nothing, with no errors. I have to manually share all of my posts. FYI in case you are involved with that plugin as well

  16. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 10 months ago #

    Jetpack's publicize doesn't need an application of it's own as far as I know, because it goes through the WordPress.com app. None of the changes you make to your app will affect Jetpack.

  17. ecrip
    Member
    Posted 10 months ago #

    Took me a while to fix too; SFC works on my site now.

    What Otto means by changing the security setting is to go to the advanced setting in Facebook developers page (Left sidebar/settings/advanced). I originally thought he was referring to a setting located within the plugin on my site.

    Once I changed the security setting for the plugin in Facebook developers the plugin once again worked like a charm.

  18. pabloibanezr
    Member
    Posted 8 months ago #

    i made the changes indicated above and it worked fine until today now is telling me>

    Given URL is not allowed by the Application configuration.: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.

    i went to re check my settings with the "Stream post URL security" option and are fine so i debuged my URL within facebook and it tells me>

    Input URL, Access Token, or Open Graph Action ID
    Scrape Information
    Response Code: 200
    Fetched URL: http://www.vendominave.com/
    Canonical URL: http://www.vendominave.com/
    Errors That Must Be Fixed
    Object Base Domain Not Allowed: Object at URL 'http://www.vendominave.com/' of type 'article' is invalid because the domain 'www.vendominave.com' is not allowed for the specified application id '236075273152208'. You can verify your configured 'App Domain' at https://developers.facebook.com/apps/236075273152208.

    any suggestions would be appreciated

    than you

    site http://www.vendominave.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic