WordPress.org

Ready to get started?Download WordPress

Forums

Subtle Background Patterns
[resolved] The plugin generated 12800 characters of unexpected output (10 posts)

  1. srumery
    Member
    Posted 1 year ago #

    I am getting the following error when I install the plugin:

    The plugin generated 12800 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    On every page of the admin panel, the plugin code is dumped on the top of the screen, pushing everything else down. Not only that, it's dumping the code at the top of the public website.

    I deleted the plugin and downloaded it again to give it another try. I got the same results.

    Any idea why this would be happening?

    http://wordpress.org/extend/plugins/subtle-background-patterns/

  2. ClubDesign
    Member
    Plugin Author

    Posted 1 year ago #

    Not yet, cause the plugin isn`t doing anything in the frontend, but inserting some js.

    Can you send me a screenshot of this happening? First time i hear about this problem, maybe some craziness with another plugin?!

    Greets

  3. ClubDesign
    Member
    Plugin Author

    Posted 1 year ago #

    Just checked back at the code, just to find out that the plugin isn`t even doing anything on activation...;)

    Not even a single line of code is executed on activation...strange. A screenshot of the output would be nice.

  4. ClubDesign
    Member
    Plugin Author

    Posted 1 year ago #

    Might be your solution:

    The plugin generated xxxx characters of unexpected output during activation.

    Try deactivating and reinstalling the plugin. Sometimes characters can get appended to a file when you use the standard FTP transfer. Please transfer using binary mode or just use the WordPress plugin uploader

  5. srumery
    Member
    Posted 1 year ago #

    Thank you for checking into the issue. I tried to download the plugin again I got the same result. No matter if I FTP or download from the repo.

    I have removed the plugin for now but will try and re-install in on another site and see what happens.

  6. kraterdesign
    Member
    Posted 1 year ago #

    Here's your problem(s) and solutions:

    1) In several defined constants you have a typo SUPPAT instead of SUBPAT.

    2) Also you should check if $_GET var subtle_msg is set before checking its contents.

    3) And there's a starting bracket missing for a P tag in subtle-backgrounds-admin.js:
    + '/p>'

    4) You are using PHP short tags, ie. <?. Always use full tags <?php as a lot of hosts have PHP short tag support disabled.

    Fix those, then deactivate and reactivate the plugin and the errors are gone (for me anyhow).

  7. ClubDesign
    Member
    Plugin Author

    Posted 1 year ago #

    Thx for the fixes kraterdesign, will be added in upcoming version...

    My guess were the PHP short tags on srumery`s problem.

    Fixed in 1.2!

  8. kraterdesign
    Member
    Posted 1 year ago #

    You're welcome!

  9. srumery
    Member
    Posted 1 year ago #

    I am happy to report that v1.2 is working great!!

    kraterdesign - Thank you for reviewing the code and providing solutions!

    ClubDesign - Thank you for applying the fix so quickly.

    WordPress has an amazing community.

    Cheers!

  10. ClubDesign
    Member
    Plugin Author

    Posted 1 year ago #

    Good to hear srumery...

    Time to give it a 5 star vote...;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.