WordPress.org

Ready to get started?Download WordPress

Forums

Ceceppa Multilingua
The plugin doesn't save (13 posts)

  1. apanciuc
    Member
    Posted 4 months ago #

    Hello Alessandro,
    The plugin doesn't save the latest modifications, i.e. - when I add a new language and then save, after refresh the language disappears. The same happends when I try to set up the default language.

    https://wordpress.org/plugins/ceceppa-multilingua/

  2. Alessandro Senese
    Member
    Plugin Author

    Posted 4 months ago #

    which version are you using?

  3. apanciuc
    Member
    Posted 4 months ago #

    I'm using 1.4.12
    I've uninstalled the plugin and cleared all tables (via uninstall from settings). The problem disapeared. However, I've met another problem ))
    The "by default" language is russian (there are 3 languages), and even though I have indicated the homepages for each language, it keeps redirecting the home page to the english version. In "Actions" settings I've checked "none" for redirection.
    I would be greatful for a solution.

  4. Alessandro Senese
    Member
    Plugin Author

    Posted 4 months ago #

    I did some tests on my machine and works for me...
    When you are redirected to english language? When you click "View site" from admin panel or when you digit your site url?

  5. apanciuc
    Member
    Posted 4 months ago #

    well, it happends in all three cases: when I enter the site, when I press View Site from admin and when I go to the home page, being on another page on the site.
    Only when I hit "view page" from admin (from the page editor) it takes me to the page.

  6. apanciuc
    Member
    Posted 4 months ago #

    Alessandro, it was a stupid thing - the plugin somehow changed the front page in the "reading settings" to the english one.
    Sorry for bothering.

  7. Alessandro Senese
    Member
    Plugin Author

    Posted 4 months ago #

    Actually the plugin change "front page" in according to current language why so wp will recognize it as "homepage" and add "home" to body classes...

    let me know if you have other problems :)

    Regards

  8. apanciuc
    Member
    Posted 4 months ago #

    Alessandro,
    Actually I have a problem with this.
    I have three languages: Russian (ID:2, default), English (ID:1) and Romanian (ID:3). The homepages, let's say: home-ru, home-en and home-ro.
    1. I had to set up the relation between the three pages manually, in the database. At the same time I have deleted the other entries of these pages in the database. Now I have just one entry with all three pages. I had to set this up manually, because when I edit the Russian page and indicate it's translations I can see the English page(home-en), but can not see Romanian (home-ro)
    2. The homepage is the Russian version, as Russian is by default. When I access the Romanian version of the homepage (home-ro), it goes to Home-ro, when I access the English version of the homepage - it goes to Home-en, but when I hit the Russian flag, it goes to Home-en. The "Front page" in the "Reading settings" is changed to "Home-en".
    3. Another problem, which is not so important, 'cause I can use another option is "Append the suffix &lang= to the url ". If I choose this option the permalink transforms into: http://welcome-transfers.com/home-en?lang=en/ and when I try to view the page it transforms to http://welcome-transfers.com/home-en?lang=en%2F and goes nowhere.
    thanks in advance

  9. Alessandro Senese
    Member
    Plugin Author

    Posted 4 months ago #

    Hi,

    1, 3) I'll do some tests...

    2) update to this version and in "Settings" -> "Advanced" tab enable "debug".
    http://www.alessandrosenese.eu/wp-content/uploads/2014/03/ceceppa-multilingua6.zip

    Let me know when you enabled the debug.

  10. apanciuc
    Member
    Posted 4 months ago #

    Alessandro,
    I've installed the plugin and enabled the debug mode. Let me know if you need access to the admin panel

  11. Alessandro Senese
    Member
    Plugin Author

    Posted 4 months ago #

    If you can let me access to your site is better, send credential to http://www.alessandrosenese.eu/contatti

  12. apanciuc
    Member
    Posted 4 months ago #

    Hi Alessandro,
    Now, when I activate the plugin, the homepage returns a "infinite loops" error and it doesn't load

  13. Alessandro Senese
    Member
    Plugin Author

    Posted 4 months ago #

    If you don't set front page all works correctly?
    Which other plugins have you installed on your site?

Reply

You must log in to post.

About this Plugin

About this Topic

Tags