WordPress.org

Ready to get started?Download WordPress

Forums

Basic Google Maps Placemarks
[resolved] The page says 'Loading map...', but the map never shows up (9 posts)

  1. radicalmarco
    Member
    Posted 3 years ago #

    Hi Ian,
    i've this problem with the plugin http://wordpress.org/extend/plugins/basic-google-maps-placemarks/ and the problem is "The page says 'Loading map...', but the map never shows up" but my theme have the calling wp_footer() right before the tag in footer.php.
    How can I fix it?
    Thanks

  2. Ian Dunn
    Member
    Plugin Author

    Posted 3 years ago #

    Hey radicalmarco, there could be several reasons why it's not working. Can you send me the address of the page so I can see it happening?

  3. Ian Dunn
    Member
    Plugin Author

    Posted 3 years ago #

    I checked out the link you sent, and it looks like the problem is that there's a JavaScript error caused by your theme's slider. Unfortunately whenever any script on a page causes an error, it prevents all the other scripts from running too.

    This is the error:
    "rot is undefined - http://photo.rivistahydepark.org/wp-content/themes/londoncreative/sliders/scripts/slider_lcp.js - Line 180"

    You'll need to contact the theme developer and ask them to fix it.

  4. radicalmarco
    Member
    Posted 3 years ago #

    Hi Ian,
    thanks I solved my problem.

  5. frankmcleod
    Member
    Posted 3 years ago #

    If I may reactivate this topic. I am also having the "page loading" but never loads problem. However, in IE and Firefox on my PC it works great. It is when I try to access it on a smartphone (Blackberry 8900). I am testing the site for my client. He uses an iPhone and says he gets a blank screen.

    When I get the "page loading" dealy on BB, it just hangs there. I do not see any way to check the JavaScript errors. Any suggestions? It is at http://dhah2011.accountsupport.com/locationmap/

  6. Ian Dunn
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Frank, I've seen it working on an iPhone and Android before, but I'm not sure about Blackberries. I don't have one to test with, so it's hard to troubleshoot. You can try looking at http://washingtonhousechurches.net/ on those devices and seeing if they work or not. If they do, then there's probably some difference between that site and yours that is causing the problem.

  7. frankmcleod
    Member
    Posted 3 years ago #

    Thanks, Ian. I looked at the link you gave me. The map comes up on BlackBerry, but no placemarks show. I would be happy with that for my simple use! :) I'll keep digging. I am using twentyeleven theme with a child style sheet. Maybe I have done something to mess it up. THANX!

  8. frankmcleod
    Member
    Posted 3 years ago #

    There was something in my sidebar code causing it, so I simply did an IF statement to remove the sidebar stuff if the post_title was the map page. But I still am not seeing the placemark icon on my BlackBerry.

  9. Ian Dunn
    Member
    Plugin Author

    Posted 3 years ago #

    If you can isolate the thing in sidebar that caused may to not show up -then I might be able to fix it.

    For the placemarks, there've been some bugs in the past that cause them to not show up in some situations, so make sure you're using the latest version of plugin (released yesterday). Other than that, I'm not sure what would cause it to fail only on the Blackberry.

    It looks like you only have 1 placemarks though, so the plugin is kind of overkill anyway. You could just use Google Map's regular embed code:

    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="http://maps.google.com/maps?q=5067+Dallas+Hwy%2BPowder+Springs,+GA+30127&dirflg=w&ie=UTF8&hq=&hnear=5067+Dallas+Hwy,+Powder+Springs,+Georgia+30127&z=14&vpsrc=0&ll=33.94121,-84.699244&output=embed"></iframe><br /><small><a href="http://maps.google.com/maps?q=5067+Dallas+Hwy%2BPowder+Springs,+GA+30127&dirflg=w&ie=UTF8&hq=&hnear=5067+Dallas+Hwy,+Powder+Springs,+Georgia+30127&z=14&vpsrc=0&ll=33.94121,-84.699244&source=embed" style="color:#0000FF;text-align:left">View Larger Map</a></small>

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic