WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] The page cannot be displayed because an internal server error has occurred error (28 posts)

  1. ttyl123
    Member
    Posted 4 months ago #

    Hi, I just installed the latest version of Better WP Security on my new site running on Azure. After the installation, I would get the following message when I try to access any of the Better WP Security options:

    The page cannot be displayed because an internal server error has occurred.

    Please help!

    https://wordpress.org/plugins/better-wp-security/

  2. mellowvision
    Member
    Posted 4 months ago #

    this seems to be happening on one of my sites as well, can not log into backend from custom url set up before the update.

  3. dravenloft
    Member
    Posted 4 months ago #

    I have this same problem.

    It has something to do with the changes BWP Security makes to the .htaccess files.

    You can get to your Admin page again by removing the entire chunk that BWPS makes and then disabling the plugin. You can re-enable the plugin and let it write fresh entries back in, but the problem will come back at some point.

    Seems to have something to do with the automatic blacklisting entries. The site will go down after some of those get written and then bring itself back up after they've had a chance to expire back out, or if you manually wipe out the plugin's entries.

    I'm looking for a permanent fix to this myself. I love the features of this plugin and have yet to find an alternative that's its equal, I'd rather find a permanent solution that's not "delete the plugin and use a different one".

  4. royedw
    Member
    Posted 4 months ago #

    So I don't know how to get to my backups or anything since I'm getting this error on my backend and front page. ????

  5. royedw
    Member
    Posted 4 months ago #

    Oh, and I use WordFence,.. NOT BWPS!

  6. cdyerkes
    Member
    Posted 4 months ago #

    Just popping in to say that this happens to me too.

    The stuff added to the htaccess is shutting down my whole site (gives me a 500 internal server error).

    I had to disable the plugin and delete all the extra htaccess entries to get it working again.

  7. lowera
    Member
    Posted 4 months ago #

    I'm having the same issue. This is a BIG problem. Please HELP!!!

  8. Matt
    Member
    Posted 4 months ago #

    Disabling the plugin/deleting the .htaccess stuff seems to be the only thing working (at the moment). Also, logging out seems to just lock out you completely out of the installation. If you're reading this and haven't upgraded yet - I would say, don't.

  9. Kattey Spares
    Member
    Posted 4 months ago #

    Same happen on my site also..for solution...

    Login via FTP and edit your .htacees file to locate and remove the below code:

    # BEGIN itheme Security

    All code in Between

    # End itheme Security

    And Change the folder name "wp-content/plugins/wp-better-security"

    to

    "wp-content/plugins/wp-better-security1"

    My Site LetHow is also facing the issue and get resolved temporary by above solution. Hope author will soon reply with more help to resolve the issue permanently...

  10. robotsforex
    Member
    Posted 4 months ago #

    Help! Right after upgrade to iThemes my admin panel crashed!!
    I see this:
    Warning: require_once(/home/domain.name/wp-admin) [function.require-once]: failed to open stream: No such file or directory in /home/domain.name/wp-content/plugins/better-wp-security/core/class-itsec-lib.php on line 514

    Fatal error: require_once() [function.require]: Failed opening required '' (include_path='.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/domain.name/wp-content/plugins/better-wp-security/core/class-itsec-lib.php on line 514

    How can I DOWNGRADE to BETTER WP security? I loved Better WP Security!! Please bring it back!

    P.S.: When I try to access admin panel via old secure link (Admin Slug) I see 404 error!

  11. lowera
    Member
    Posted 4 months ago #

    All, it looks like ITheme Security just released their 4.0.1 release:

    According to the Changelog:

    "4.0.1

    Fix for issue whereas a blank deny ip line could be entered into wp-config.php during update if banned users was used."

    I'm not going to update this until I see some proof it works...major #fail Better WP Security...

  12. Tim Gary
    Member
    Posted 4 months ago #

    On "upgrade" the .htaccess file has bad code in it that brings down the server.. to fix, try the following...

    If the beginning content in the file beginning of the file looks like:

    # BEGIN iThemes Security
    # BEGIN Ban Users
    Order allow,deny
    Deny from
    Deny from 176.53.65.71
    Deny from 141.138.204.113
    Allow from all
    # END Ban Users

    Remove the entire line that just has "Deny from" on it, so that it looks something like:

    # BEGIN iThemes Security
    # BEGIN Ban Users
    Order allow,deny
    Deny from 176.53.65.71
    Deny from 141.138.204.113
    Allow from all
    # END Ban Users

    Note, the IP addresses shown will likely be different for each site, and there could be many more of them, or none at all. Just remove the line indicated and leave the rest.

    Hope this helps.

  13. Matt
    Member
    Posted 4 months ago #

    Having the same issue here. Removing all ithemes security related .htaccess entries fixes the issue. Did not have line containing only "Deny From" as Tim mentioned above, so couldn't try that.

  14. Matt
    Member
    Posted 4 months ago #

    Latest update fixes this issue. For safety, I deleted the entire contents of the plugin folder, downloaded the latest version, and uploaded all contents via FTP and reactivated. Works.

  15. lowera
    Member
    Posted 4 months ago #

    Thanks, Tim Gary, it appears that the 4.0.1 release addresses that issue.

  16. Matt
    Member
    Posted 4 months ago #

    I've isolated the issue to any rules related to banned users on my installation (not HackRepair.com's blacklist).

    This actually isn't addressed by 4.0.1. That updated fixes an issue where a blank line is inserted into wp-config.php, not .htaccess. I'm fairly certain there's still an issue with the banned users .htaccess rules themselves. When I remove them the site is fine. When they're included the site goes down. I've confirmed there is no blank line in wp-config.php.

  17. fanvid
    Member
    Posted 4 months ago #

    yep happened to me too, i just disabled it, second time wp-security had this "update turns off site" kind of thing... pretty disappointing start! as of now its disabled on all my sites...

  18. Chris Wiegman
    Member
    Plugin Author

    Posted 4 months ago #

    The 4.0.1 should address the issue. Please contact me directly if you still see it. With over 100 sites personally upgraded and testing I have not been able to reproduce the error and I would love to see both the .htaccess and plugin conflict of anyone who is experiencing the problem with 4.0.1.

    As much as I would love to say I could test for every configuration out there, it just isn't possible. That said, with a little data we'll get to the bottom of it and fix it ASAP.

  19. Matt
    Member
    Posted 4 months ago #

    Below are the rules that cause the problems for me. Removing them removes the problem. All other iThemes Security related rules are fine.
    The only other lines in my .htaccess are from W3TC.

    Order allow,deny
    		Deny from 101.64.0.0
    /8/16/16/16
    		Deny from 109.194.0.0
    /8/16/16/16
    		Deny from 109.87.0.0
    /8/16/16/16
    		Deny from 115.195.0.0
    /8/16/16/16
    		Deny from 123.152.0.0
    /8/16/16/16
    		Deny from 125.118.0.0
    /8/16/16/16
    		Deny from 134.249.0.0
    /8/16/16/16
    		Deny from 178.215.0.0
    /8/16/16/16
    		Deny from 178.94.0.0
    /8/16/16/16
    		Deny from 193.169.0.0
    /8/16/16/16
    		Deny from 194.146.0.0
    /8/16/16/16
    		Deny from 194.165.0.0
    /8/16/16/16
    		Deny from 37.45.0.0
    /8/16/16/16
    		Deny from 37.57.0.0
    /8/16/16/16
    		Deny from 41.107.0.0
    /8/16/16/16
    		Deny from 46.118.0.0
    /8/16/16/16
    		Deny from 60.176.0.0
    /8/16/16/16
    		Deny from 60.177.0.0
    /8/16/16/16
    		Deny from 77.123.0.0
    /8/16/16/16
    		Deny from 77.93.0.0
    /8/16/16/16
    		Deny from 79.135.0.0
    /8/16/16/16
    		Deny from 80.64.0.0
    /8/16/16/16
    		Deny from 94.153.0.0
    /8/16/16/16
    		Deny from 88.245.50.214
    		Allow from all
  20. CrimsonMoon
    Member
    Posted 4 months ago #

    I had to delete everything related to iTheme in the .htaccess file, including:

    # BEGIN iThemes Security
    # END iThemes Security
  21. lowera
    Member
    Posted 4 months ago #

    My issue was resolved when removing the following line from .htaccess:

    Deny from

    That was causing an internal server error and none of my pages were loading.

  22. rpsellers
    Member
    Posted 4 months ago #

    I'm still scrolling through all the comments but this "upgrade" from WP better security to the new ithemes security has already killed two of my websites completely. NOT exactly what we were looking for folks... This particular "upgrade" is so far an F-ing disaster. I'm disabling and removing wp better security on every site and looking for something else until this disaster is fixed.

  23. Matt
    Member
    Posted 4 months ago #

    Try removing the lines in .htaccess related to banned hosts. That should get your site back online. They'll probably roll out a permanent fix shortly.

  24. Chris Wiegman
    Member
    Plugin Author

    Posted 4 months ago #

    Thank you to Matt Zak for the data. I've fixed the issue and pushed version 4.0.2 to resolve. Also updated my unit tests with an extra test case (tested every combination of wildcard ip except multiple *s).

  25. Matt
    Member
    Posted 4 months ago #

    Updated and it works fine for me. Thanks!

  26. CrimsonMoon
    Member
    Posted 4 months ago #

    Same! Updated to version 4.0.2 and everything went smoothly. :) Thanks for the quick response to this issue!

  27. arianec
    Member
    Posted 4 months ago #

    Since updating to 4.0.2 all seems good BUT each time I go to my WordPress Dashboard, I'm asked to log in as if I'd logged out five minutes ago. This is getting very annoying. Anyone else find this problem and a solution? I'm running on a Mac using WP 3.8.1

  28. sjk1000
    Member
    Posted 3 months ago #

    Somehow the host I'm forced to use has the site on Microsoft-IIS/7.0. I've no idea how that works as I've never needed to go there. I get an internal server error and locked out. Will ftp in and run the backup. As you say, you can't test on everything so this is an FYI
    Keep up the great work.

Reply

You must log in to post.

About this Plugin

About this Topic