WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
The page cache rules could not be modified. Please run chmod 777 (12 posts)

  1. SRD75
    Member
    Posted 1 year ago #

    I have W3 Total Cache installed in a WordPress network, and I have just activated the plugin on the first network website.

    When I try to turn page caching on, I receive the following errors:

    The page cache rules could not be modified. Please run chmod 777 /.../wp-content/w3tc-siteurl/pgcache to resolve this issue.

    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    Disk enhanced page caching is not active. To enable it, add the following rules into the server configuration file (/.../wp-content/w3tc-siteurl/pgcache/.htaccess) of the site . This can be done automatically, by clicking here: .

    1. I have chmod /wp-content/w3tc-siteurl/pgcache to 777.
    2. .htaccess exists in the web root, and has permissions of 777
    3. the rules mentioned in the 3rd error already exist in that particular .htaccess file

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Have you tried using the latest release 0.2.9.6 ? deactivate old one and remve it and then install latest. Then on network admin plugins network activate.

  3. SRD75
    Member
    Posted 1 year ago #

    I removed the old version, downloaded, unzipped, uploaded the new version.

    When I try to activate the plugin, I receive:

    Fatal error: Uncaught exception 'FileOperationException' with message '.../wp-content/w3tc-config/master.php could not be created, please run following command:
    chmod 777 .../wp-content/w3tc-config'
    in .../wp-content/plugins/w3-total-cache/inc/functions/activation.php:117 Stack trace:
    #0 .../wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(159): w3_throw_on_write_error('/usr/local/pem/...')
    #1 .../wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(421): W3_ConfigWriter->save()
    #2 .../wp-content/plugins/w3-total-cache/inc/functions/update.php(58): W3_ConfigWriter->import_legacy_config_and_save()
    #3 .../wp-content/plugins/w3-t in .../wp-content/plugins/w3-total-cache/inc/functions/activation.php on line 117

    I can't CHMOD w3tc-config because the owner of this folder is incorrect; I think it is set to Apache, while the rest of the folders are set to my hosting userid.

    I will have to ask my web host to change the ownership.

  4. SRD75
    Member
    Posted 1 year ago #

    The web host has changed ownership of folders for me, and I can now network activate the plugin.

    A bit cumbersome that I have to wait for my webhost to do this for me.

  5. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    The latest release has better write handling to limit these cases. If all is resolved please mark thread as resolved.

  6. SRD75
    Member
    Posted 1 year ago #

    Okay.

    One more thing.

    When I try to go to
    /wp-admin/admin.php?page=w3tc_general

    I receive:
    You do not have sufficient permissions to access this page.

    My user account is an administrator account.

  7. hotzeplotz
    Member
    Posted 1 year ago #

    same here (permissions error for URI /wp-admin/admin.php?page=w3tc_general) after upgrade to 0.9.2.8 on a network.

    w3tc was activated only on a site within the network, and after the upgrade i do not see it anymore in the site's admin interface: i can only enable or disable it for the whole network, and yet when i do this, only a subset of the admin pages for the plugin appear in the admin navmenu: Dashboard, FAQ, Support, About. if i enter <base_URI>/wp-admin/admin.php?page=w3tc_general manually i get the above mentioned permissions error - yet i'm logged in as administrator.

    tried deleting the configuration file for this site, but this didn't solve the issue. i get the w3tc comment at the bottom of each page's source, but e.g. CDN serving which was enabled before the upgrade is not active (media library items URIs are not rewritten to go through the CDN servers).

  8. symbolscape
    Member
    Posted 1 year ago #

    Same problem after update to 0.9.2.8. I'm locked out of my admin. No bueno.

  9. hotzeplotz
    Member
    Posted 1 year ago #

    in my case, it seems that the major issue on this upgrade was lack of clarity on the admin interface changes: i only realised after a good deal of tests that W3TC now defaults to applying the same settings across a whole WordPress network, so it is "normal" that most of the W3TC admin pages don't appear in the control panel of individual sites: once this default is overridden in the W3TC configuration at network level, any enabled admin pages will be available on each site.

    i guess that the message appearing on each site's W3TC Dashboard page ("The plugin is currently enabled in community mode.") doesn't really mean much (what is 'community mode'? a link to an explanation would be helpful), whereas a message on this page informing admins that W3TC configuration is being applied from network-wide settings would clearly help, especially as this behaviour seems to be a radical departure from older versions of W3TC (once i realised how this works, this is great, but i wasted a couple of days just trying to figure out what was wrong with this plugin's upgrade).

    changed my vote for 0.9.2.8 on 3.5.1 to say 'works' - but clearer notes on upgrade and on each site's W3TC dashboard would really help.

  10. MadAsApples
    Member
    Posted 1 year ago #

    If PHP Safe Mode is switched on for your hosting account it can cause file permission errors. If you can, try switching it off

  11. omkarbhide
    Member
    Posted 1 year ago #

    Hi,

    Its the same with me. I upgraded my W3TC plugin, to latest 0.9.2.8 version. After the upgrade, it is only possible to Network Active the plugin, after which I get all the options in the Performance section.

    But this is not what I want, I want it to use on individual site, but when I check the plugin list in the site interface I am not able to see W3TC in the list.

    Strange.. This didn't happen in the previous version, 0.9.2.4

    Thanks

  12. lukeyj
    Member
    Posted 6 months ago #

    Hi guys, I have read about 10 posts on this topic, yet still seem to be having trouble.

    my /wp-content/ & /wp-content/uploads/ folders are 777
    my /wp-content/cache/tmp/ is 777

    I have tried all the suggestions of other posts, including:

    Deactivate plugin
    Remove all plugin files
    Reinstall plugin
    Make sure wp-content/ owner:group apache:apache or has 777 permissions
    Activate plugin

    The plugin appears to install fine, but I have an error stating: "W3 Total Cache: Default settings are in use. The configuration file could not be read or doesn't exist. Please to create the file." as mentioned in another post. I also have the same problem here of when I check the "Enable Page Cache" check box I get another error message and when the page reloads it is unchecked again.

    The secondary message that appears after trying to save is this one:
    "Can't change configuration: Can't write to file /var/www/vhosts/XXXXX/httpdocs/wp-content/w3tc-config/master-admin.php"

    When I log into the server I can see that the /w3tc-config/ is 755 but the owner is apache. There is no master-admin.php file in the /w3tc-config/ and I can't add one or change the permissions to 777.

    Do I need to get my server admin to change something here or have I overlooked something obvious?

    Thanks :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags