WordPress.org

Ready to get started?Download WordPress

Forums

The package could not be installed.: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to fin (14 posts)

  1. MtnXfreeride
    Member
    Posted 5 months ago #

    Ive been getting this message with every update for the 6 months, before that everything worked fine and one day no plugins would auto update and no more wordpress automatic updates, I really want to stop doing manual updates and fix this problem once and for all... But I have no idea whats actually causing this issue? There were no changes on my end in the sever settings etc..

    "The package could not be installed.: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature"

    Im using Digital Ocean VPN hosting. I have 10s of GBs disk space available and barely touching the available memory.

    Help is greatly appreciated, and please dont just tell me to manual update.. that doesn't actually fix the problem!

  2. Josh (WP Edit)
    Volunteer Moderator
    Posted 5 months ago #

    This message means that the file (package) is either...

    1. Not a proper .zip WP structure format.
    2. Not able to be extracted properly due to system quota constraints.

    Your system quota constraints aren't necessarily limited to just disk space and memory.

    What version of PHP are you running on your server?

  3. MtnXfreeride
    Member
    Posted 5 months ago #

    Josh, thanks for the reply,
    1. Not a proper WP structure format. I guess I don't know what you mean by this.

    2. PHP 5.4.6-1ubuntu1.2 (cli) (built: Mar 11 2013 14:54:18)

    12GB of disk space available

    Filesystem Size Used Avail Use% Mounted on
    /dev/sda 20G 7.4G 12G 40% /
    udev 1007M 4.0K 1007M 1% /dev
    tmpfs 404M 240K 404M 1% /run
    none 5.0M 0 5.0M 0% /run/lock
    none 1009M 0 1009M 0% /run/shm
    none 100M 0 100M 0% /run/user
    overflow 1.0M 0 1.0M 0% /tmp

  4. MtnXfreeride
    Member
    Posted 5 months ago #

    KiB Mem: 2065392 total, 1520032 used, 545360 free, 138464 buffers
    KiB Swap: 4194300 total, 324 used, 4193976 free, 1153032 cached

    load average: 0.00, 0.01, 0.05

  5. Josh (WP Edit)
    Volunteer Moderator
    Posted 5 months ago #

    1. Not a proper WP structure format. I guess I don't know what you mean by this.

    WP has a certain way of 'building' the .zip files for core, themes, and plugins. If this template is not followed, it will result in a bad .zip file.

    However, if you are having this issue updating core itself, then this is unlikely to be the problem.

    How exactly are you attempting to update core? Are you clicking the Update WP button from within the admin panel?

  6. MtnXfreeride
    Member
    Posted 5 months ago #

    How exactly are you attempting to update core? Are you clicking the Update WP button from within the admin panel?

    Yes, in my admin page I see

    WordPress 3.7.1 is available! Please update now.

    I am clicking update now, then the update button,
    then it is asking for my FTP information. I have quadruple checked my FTP address/user/pass to be correct and match with what is working fine in FileZilla.

    Then it says this:

    Downloading update from http://wordpress.org/wordpress-3.7.1-no-content.zip…

    Unpacking the update…

    The package could not be installed.: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    Installation Failed

    Is it not normal for wordpress to ask for this information to even do an update? On a side note, I am able to drag and drop photos into my posts which upload without issues.

  7. Josh (WP Edit)
    Volunteer Moderator
    Posted 5 months ago #

    then it is asking for my FTP information.

    This is a concern. It should not be happening (unless you have configured a plugin or perhaps your .htaccess file with a custom modification).

    I would put my money that this is your issue. Fix that, and things will probably work properly again.

    I have come across that issue once or twice before... but forget the exact solution. Again, I'd check for a plugin or a custom modification to your .htaccess file... or a setting in your wp-config.php file.

  8. MtnXfreeride
    Member
    Posted 5 months ago #

    .htaccess file reads:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
    <IfModule mod_headers.c>
    Header append Vary User-Agent env=!dont-vary
    </IfModule>
    AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
    <IfModule mod_mime.c>
    # DEFLATE by extension
    AddOutputFilter DEFLATE js css htm html xml
    </IfModule>
    </IfModule>
    # END W3TC Browser Cache
    # BEGIN WordPress

    # END WordPress

    As far as I know I never touched it or my config.php file.

    I heard someone once say it had to do with users and permissions, but nothing more than that.

  9. MtnXfreeride
    Member
    Posted 5 months ago #

    ugh the problem is now deeper than just wordpress, I just logged into FTP and went to add my FTP info to the config file to se eif that fixed it.. but I cannot over write the old wp-config file or even delete it, or change permission. wtf happened?!?! How did I even manually do this last time?

  10. Josh (WP Edit)
    Volunteer Moderator
    Posted 5 months ago #

    What are the permissions on your wp-config.php file?

  11. MtnXfreeride
    Member
    Posted 5 months ago #

    0644. But I think this is an issue of the user I created and use to connect to FTP and also FTP through wordpress (when it asks for my info)... How do I edit the user so it can do these basic things in ubuntu?

    My www directory is located at root/var/www/ and I think the way I set up my LAMP server where the www directory isnt in the home/username is screwing it up.

  12. Josh (WP Edit)
    Volunteer Moderator
    Posted 5 months ago #

    I think you are absolutely correct.
    I'm pretty sure those usernames must align.

    It's a little beyond my pay grade... so I'm afraid I can't offer much help in this area. But, I'm fairly certain you have identified the correct issue.

    Please keep me posted, and any fix you find.

    Thanks!

  13. MtnXfreeride
    Member
    Posted 5 months ago #

    root@domain:~# adduser myusername www-data
    The user myusername' is already a member ofwww-data'.
    root@domain:~# chown myusername:www-data -R /var/www
    root@domain:~# chmod 0755 -R /var/www
    root@domain:~# chmod g+s -R /var/www

    This finally fixed my plaguing issue, thanks for your help along the way... it took quite a bit of googling and pointing.

  14. Josh (WP Edit)
    Volunteer Moderator
    Posted 5 months ago #

    Congrats!!

    Yep.. I would have had to do the same. But man... you did it!!

Reply

You must log in to post.

About this Topic

Tags