WordPress.org

Ready to get started?Download WordPress

Forums

The Other - not sufficient permissions to update blog (8 posts)

  1. wenu
    Member
    Posted 5 years ago #

    From 2.7 to 2.7.1

    The 2.7.1 Upgrade says you do not have sufficient permissions to update plugins for this blog. (I update them all the time!)

    I have all the access [admin] and I can do all the other updates and I know the passwords etc for running Stats and the like.

    Tried deactivated All Plugins - no effect.

    This is the only error message I get and it's in a white box against a grey field (page background).

  2. Samuel B
    moderator
    Posted 5 years ago #

    it is talking about server permissions
    in other words, who owns the server?
    apache? host? your username?

    ask your host to fix server permissions so you can do this auto upgrade from now on.

  3. wenu
    Member
    Posted 5 years ago #

    Thank You, samboll !

    I'll try that. Usually I have nothing to do with them except to make sure the monthly bill is paid. Wonder if I remember how to contact them!

    Here goes . . .

    I post your answer in my request - I suspect what you said makes more sense than my questions.

    Wen U

  4. wenu
    Member
    Posted 5 years ago #

    No luck so far. He did something and asked me to try it. There was no change so I asked for more help on the ticket.
    I WILL keep you posted - the Forum too for that matter.

  5. wenu
    Member
    Posted 5 years ago #

    OK
    My host provides DirectAdmin (tm) under which I run my blog domain. It seems from what he says that I cannot run the kind of Automated Upgrade that WordPress has introduced with WP Version 2.7 and above. At least, he says he can't see why it won't operate - "I'll dig into it a little more, however I don't see any obvious solution." he says.
    Under my host's direction I messed a bit with Permission settings (in the wp-admin folder) but that made no difference.

    I was able to update SEO All-In-One (icluding the API validation procedure) without hassles while WP 2.7 was running so it seems thaere is no problem so far as the ACTUAL Plug-ins are concerned.

    QUESTION: Does anyone else in the Forum have DirectAdmin site administration software and have they experienced a similar problem??

    QUESTION: Can WordPress revise the Upgrade Software so that those of us operating under DirectAdmin can also use it? Or suggest a fix?

    My Host is CyberWurx and they are very helpful, including now, aside from not removing this hiccup. My Host supplied the Blog, running under an earlier version of WordPress, and I expected it would continue to run smoothly. Has done for well over a year. (The blog was on another Host before that - on Joomla too)

    I manually upgraded to WP 2.7.1 and the Blog is fine.
    Just for stamps I clicked on the Tools/Upgrade link, despite the Dashboard saying I have ver. 2.7.1 and Yes - it came up still with the same message: "you do not have sufficient permissions to update plugins for this blog".

    I would really like to be able to run the Automatic Upgrade by the time 2.8 comes out. I think it's due about March?

  6. kansir
    Member
    Posted 5 years ago #

    My web host uses DirectAdmin too.
    I can't use the new auto upgrade function.

  7. wenu
    Member
    Posted 5 years ago #

    Thank You, kansir!

    I am working through it with my Host and will next look at the Folder and File 'permissions' in the plugins folder.

    But - shops first! Charge it!

  8. wenu
    Member
    Posted 5 years ago #

    This is two straight days I thunked on this and still unthunked the answer.
    Permissions seem OK. Using 755 I can upload graphics to the wp-contents/uploads/2009 folder with no hassle. I think that demonstrates I can enter the Site Admin (Dashboard) area, create a new document and upload graphics to it using the permissions I have generally configured throughout the Directory Tree. Meaning I think they follow general convention.
    But when it comes to running what I term a Global Update on WordPress itself, in the Domain, uh uhh! Suddenly I do not have sufficient permissions. My Host can't find a reason why and he feels it's related to how WP 2.7 interacts with apache in the DirectAdmin environment. (or words to that effect)
    For the record, I cannot find a single place within the Directory Tree where .htaccess does NOT cause the site to crash. I have a copy of the syntax that was in it once before:
    RewriteEngine On
    RewriteCond %{REQUEST_URI} !^/~username/blogname.com(.*) [NC]

    RewriteRule ^(.*)$ /~username/blogname.com/$1

    THAT is fatal to the Blog. My only access with that anywhere in the tree is back through DirectAdmin control panel file manager. Is it the syntax? Or does that also conflict with WP 2.7?
    I ran out of clues shortly before I appealed to the Forum.
    Wen U

Topic Closed

This topic has been closed to new replies.

About this Topic