WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Change size of editor missing in WP 3.5???? Help (33 posts)

  1. ebizdame
    Member
    Posted 1 year ago #

    How to Change size of editor in WP 3.5

    The size of the editor is small and I wanted to change that. In the previous version I went to writing and on the top there was an option to change "size of post box"

    This seems to be missing in WP 3.5.

    Can someone advise me how to change the size?

    Thanks

    Dita

  2. Hi ebizdame,

    In the post-editing screen, if you switch from the Visual tab to the Text tab, and you look down in the right-hand corner of the editor box, you should see a small triangle that you can drag down-ward to increase the height of your editor box. Once you've adjusted the height, WordPress will remember your setting.

  3. ebizdame
    Member
    Posted 1 year ago #

    Hi Drew,

    I tried that. Unfortunately, it does not remember. The box is really small. Funny that this happened because I am seeing it in the previous version as well. And I have not seen it this earlier today when I was creating my pages.

    When I move the triangles it enlarges the box but when I go to visual it reverts back to about 7 lines. There is nothing I can do with this.

    Real mystery. I tried a different theme as well and I am encountering the same problem.

    I have tried to upload a picture and can hardly see anything.

    Hope you have suggestions. I am completely stumped.

    Thanks,

    Dita

  4. TechHamlet
    Member
    Posted 1 year ago #

    I also face the same problem... I can't work with a tiny editor. I used a larger editor for several years!

  5. ebizdame
    Member
    Posted 1 year ago #

    Hi TechHamlet,

    I still have the problem but I was able to overcome it. Drew suggested to go into the text editor and adjust the height there. It did not work.

    I noticed late last night that you can actually adjust it in the visual editor. In the very right hand of the box, (not the scroll bar)just the same as if you were expanding an image, pull on it (press the click button and don't release). Essentially you are dragging it to become larger.

    I saved it, left the page and it still was preserved. It seems to preserve your enlarged option also for other posts/pages.

    Hope this helps

    Dita

  6. WormholeRiders
    Member
    Posted 1 year ago #

    Hi everyone,

    Thanks to Drew for posting a response on "Edit Box Size".

    Am a huge supporter of WordPress on hosted (leased) Linux server sites. Do a fair amount of tech support for friends. Most times since version 2.x.x I just look at (read) the code, the changes, security issues, and typically upgrade.

    The work-around as Drew described worked for me as a fix in Text (formerly HTML) Mode. It also works in Visual Mode as Ebixdame (Dita) described. Both also apply to new posts (for each author who applies the fix) that are created afterwards.

    However, we have dozens of installations and many of our reporters are not tech savvy. Since WormholeRiders (WHR) runs over 30 WP news sites, and based on the number of other challenges described, we are going to hold off moving from version 3.4.2 for a bit.

    Keep up the great work WordPress Team! Thank you!

    Best Regards,

    Kenn

  7. ebizdame,

    I think I got it backwards. I rarely use the Visual editor :)

  8. masnart39
    Member
    Posted 1 year ago #

    Thanks for the info, but the resize - then save doesn't work for me in either visual or text mode.

    I'm not sure why such a popular option as modifying the size in the "writing" settings would be removed from the admin. Seems like there are alot of small things eliminated during updates that cause people to waste time searching for solutions that shouldn't exist.

    If there is a way to modify one of the core files to set the post box to my prefered size, I'd be very thankful to know about it.

    Nick

  9. enduro bikes
    Member
    Posted 1 year ago #

    Thanks for the workaround and it does work in visual editor, have not tried HTML view. I have to say this is probably a better way to re-size the window as you can now visually see how big you want it to be. I have to say though that I have noticed a number of other things in this update that have had me scratching my head to wonder why?

  10. Xue Faith
    Member
    Posted 1 year ago #

    Hi all, just wanted to FYI you that there seem to be 2 different threads on this same issue:
    http://wordpress.org/support/topic/number-of-lines-in-post-box-issue

    As said in both places, I hope this is a bug! It seems to stick for some peeps, but even if it doesn't, what a pain to have to resize it 50 times a day when there used to be a setting.

    I'm with Wormholeriders - I've unfortunately already upgraded some sites to 3.5, but the ones I haven't I think I'll keep at 3.4.2. The new media tool is sexy, yes, but I think the size of post box is really important. Or maybe I'm just being bratty over a deprecated feature I liked. IDK...

    While I *hope* it's a bug, it's been that way on WP.com for several months now, so I fear it may be intentional.

  11. inge12
    Member
    Posted 1 year ago #

    I have the same issue, except that my editor window is HUGE - many pages long. And resizing it does not "stick." Even after saving a post, the editor springs back to the HUGE size.

  12. Robert
    Member
    Posted 1 year ago #

    +1

    The Post Editor on WP 3.5 automatically expands to the full length of the post. Dragging the triangle control in the bottom right corner of the editor pane to make it shorter isn't remembered in both Visual and Text mode. A real annoyance!

  13. Juhan108
    Member
    Posted 1 year ago #

    (Please see also the similar topic: "Number of Lines in Post Box":
    It could likely be a WP 3.5. compatibility issue with Internet Explorer. Trying other browser could help!

  14. Robert
    Member
    Posted 1 year ago #

    I've tried the latest versions of Chrome and FireFox on Win7. No joy.

    Wonder if there's a database parameter that can be manually set via PhpMyAdmin?

  15. Robert
    Member
    Posted 1 year ago #

    I confirmed this is a bug in WordPress 3.5 that was found during development and the developers thought the bug was fixed. I ran a test while watching the wp_usermeta -> wp_user-settings -> ed_size= value in PhpMyAdmin and viewing the cookie wp-settings-58, Content: ed_size.

    In brief, the ed_size field sets the post box editor height in pixels and the value is saved in a browser cookie. ed_size was being set to 33339999997615814 pixels, the actual value will vary somewhat. Setting the value to something reasonable like 600 pixels in PhpMyAdmin won't survive a post update.

    Reference:
    Ticket #22708
    Post edit page may become almost unusable and textarea cannot be resized
    http://core.trac.wordpress.org/ticket/22708

    I updated the ticket with the test sequence, database and cookie values.

    We'll have to wait for a WP 3.5 patch.

  16. Robert
    Member
    Posted 1 year ago #

    Ticket #22708 has patch files issued:
    http://core.trac.wordpress.org/changeset/23016
    * wp-admin/js/post.js (4 diffs)
    * wp-includes/class-wp-editor.php (1 diff)

    with a follow-up change here:
    http://core.trac.wordpress.org/changeset/23017
    * wp-includes/class-wp-editor.php (1 diff)

    The patches perform an sanity check on the ed_size value and sets the post editor to 5000 pixels high if ed_size > 5000. That's almost 5 screens high on my 1920w x 1080h monitor resolution and very annoying.

    I installed the new files on my WP 3.5 staging environment and tested with FireFox and Chrome. The editor size bug remains and the post editor is continually reset to 5000 pixels. My workaround was to change the ed_size code from 5000 to 500 pixels in the above source code files. If you decide to make changes on your server, make copies of the original .js and .php files and be careful! e.g.
    a. copy post.js to post.js_original
    b. upload the patched post.js
    c. do the same for class-wp-editor.php
    CPanel -> FileManager is very convenient here. This assumes your hosting WordPress on your own server and won't work if your site is on WordPress.com.

    I opened a new bug ticket http://core.trac.wordpress.org/ticket/23042 because the underlying ed_size bug isn't fixed.

  17. Scaramanga XXX
    Member
    Posted 1 year ago #

    @Robert
    Thanks for information about patching the two files/ed_size. I changed to 800 what is similar to my settings in 3.42 before. That helps for now.

  18. Scaramanga XXX
    Member
    Posted 1 year ago #

    Hopefully there will follow an official patch soon:)

  19. missinmedia
    Member
    Posted 1 year ago #

    If you are using the Qtranslate plugin I've used a quick and dirty solution through CSS.

    In plugins Qtranslate click on Edit
    select this file: qtranslate/qtranslate_hooks.php

    scroll down until you find this line:
    echo "#qtrans_textarea_content { padding:6px; border:0 none; line-height:150%; outline: none; margin:0pt; width:100%; -moz-box-sizing: border-box;";

    Inside this CSS I've added height:400px;

    Looks like this:

    echo "#qtrans_textarea_content { padding:6px; border:0 none; line-height:150%; height:400px; outline: none; margin:0pt; width:100%; -moz-box-sizing: border-box;";

    Hopes this helps some people for a while, you can set any height you wish it to be. It's very quick and dirty at least it solves the annoyance of having to drag it all the time ;)

  20. Andrew Ozz
    WordPress Dev
    Posted 1 year ago #

    Still not able to reproduce this... The ed_size would not be saved if the value is too big or too small, only when it's in the range 50px -- 5000px.

    Added a patch on the new ticket few days ago: http://core.trac.wordpress.org/attachment/ticket/23042/23042.patch

    @Robert, @missinmedia could you check if that patch fixes it for you? Also can you try resizing the Text editor too.

    To see the current ed_size that is in your cookie run this in the browser console:

    getUserSetting('ed_size');

    After resizing the editor, the returned number should change accordingly. Also, to set it manually you can do:

    setUserSetting('ed_size', 200);

    The change should be visible after reloading the page.

  21. Xue Faith
    Member
    Posted 1 year ago #

    Hey Andrew! Sorry to be a remedial noob, but how do you run that in the browser console?

    And, any chance that the Number of Lines for the Editor setting we used to have in 3.4.2 will return?

  22. Andrew Ozz
    WordPress Dev
    Posted 1 year ago #

    To run it go to Edit Post screen and:

    - In Chrome right-click anywhere on the page and select "Inspect element". That will open the developer tools at the bottom, click on the Console tab, then paste that JS code and press Enter.

    - In Firefox go to "Web developer -> Web console" from the menu at the top or if you have Firebug, go to the console there. Paste the JS in the thin box at the bottom and hit Enter.

    - In IE > 8 hit F12, go to the Console tab, paste in the box at the bottom and hit Enter.

    Don't think that setting will return. It was mostly irrelevant as it would affect only the Text editor and only when the Visual editor was never used. As soon as the user resized the Visual editor, the textarea height was matched to it.

  23. nancyeb01
    Member
    Posted 1 year ago #

    Andrew, Thank you for this tip.
    I'm getting this number in Firefox "64476666". It is quite high.

    After resizing the post edit box to about an inch and a half high, I get this number: "15276666".

    The set user edit size to 200 works. After I use it the number in Firefox is: "200"

    But, is that only for me as the logged in user?

    This is of great concern as I created this site for non WP saavy folks to login and create posts. Below the post edit box are the custom fields they need to access. They won't know they are there at this point.

    Thank you for any help in getting back to a manual box size setting.
    Nancy

  24. Andrew Ozz
    WordPress Dev
    Posted 1 year ago #

    @nancyeb01 the editor height is per-user setting, so other users will have a value there after they resize the editor or will use the default of 360px.

    It would be very helpful to track where these huge values come from. Have you used 3.5-beta before updating to 3.5 (final)? Also what browsers/versions have you used the first time you saw this and right before that. Are you still able to reproduce this (the huge number for 'ed_size') when you resize the editor now?

  25. inge12
    Member
    Posted 1 year ago #

    I get huge editor heights, and I did not use any beta version before updating to 3.5 final. Resizing does not "stick." (I have not taken the time to try to fix this. It really should work out of the box!)

  26. @inge12: It's impolite to interrupt another poster's ongoing thread with a question of your own and it causes significant problems for the forum's volunteers. Please post your own topic.

  27. Scaramanga XXX
    Member
    Posted 1 year ago #

    @Andrew:
    Today I deleted the old cookie-file and changed the two files I patched before (as described by Robert here in this thread) back to the original ones. Now the editor size seems to work perfect. It "remembers" the size of the edor window and doesn't "explode" to giant size as before.

    Deleting the old cookie-file solved - as far as I can see in the moment - the problem for me now.

  28. Steve
    Member
    Posted 1 year ago #

    Thanks @Andrew Ozz, the console JS update seemed to have sorted it for me, im going to check the other users who are Authors to see what there Post Box is like.

    Cheers
    Steve

  29. nancyeb01
    Member
    Posted 1 year ago #

    @Andrew:
    I don't think I used 3.5-beta before updating to 3.5. The version of Firefox I am using is 17.0.1 and believe I have been on for a few weeks (I am on the release update channel) I get the same long edit field in IE 9.

    I just ran some tests to see if it was my theme or plugins. I tested on a site with WP 3.4.2; no active plugins running and WP theme 2012.

    I upgraded the site to 3.5. I still have the extremely long window - size was "432876666" in one instance. Sometimes it holds the re-size, sometimes becomes extremely long. This is true in Firefox and IE.

    I will continue testing.

    Thanks for your thoughts on this. If you need a login please let me know.

  30. nancyeb01
    Member
    Posted 1 year ago #

    @Robert and @Andrew:
    I applied the above patches, and took Roberts advice to "change the ed_size code from 5000 to 500 pixels". That seems to work.

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic