WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
The New Upgrade BLOCKED me from admin login page and more... (10 posts)

  1. lavieenrose
    Member
    Posted 3 years ago #

    When I downloaded the new version. I received huge error that blocked me from logging into my wordpress admin control panel... so basically, it shut me down.

    I got the follow error message: "Fatal error: Class 'WP_List_Table' not found in /home2/mybluehostloginname/public_html/wp-content/plugins/nextgen-gallery/admin/manage-images.php on line 646"

    I called bluehost to help, they showed me the steps on how to deactivate plugins from within bluehost--- and I did that.

    Then I deleted and downloaded the past version, which worked but undid all my previous shadowbox/lightbox next-gen gallery coding I guess... because now when a photo is clicked on in my website there's no more shadowbox/lightbox, it just goes to the photo in the basic way.

    I'm not too savvy at this stuff, so it sux pretty bad when I upgrade and it messes up my website... it gives me horrible anxiety b/c I run a pretty large site and I do everything....

    I have wordpress 3.0.1 btw. Too paranoid to update b/c I don't want to run into more issues, like this one.

    Anyone have a clue on how to get it back, on how to use next-gen with the lighbox/shadowbox and make it so when someone clicks on a photo they get a very nice shadowbox/lightbox of the image or several images (gallery)???

  2. sethhumphrey
    Member
    Posted 3 years ago #

    Did you update through WP or did you just FTP the new files? When I updated through WP, it prompted me to update the Database b/c it was no longer in sync. I'm guessing that's why I didn't have this problem.

  3. lavieenrose
    Member
    Posted 3 years ago #

    I updated through wordpress too... but after it messed me up, gave me the error, and blocked me from the admin/control panel I had to delete the plug-in via bluehost, then I could login again...

    That's when I downloaded an older version...

    I forgot which one I had before, so I first tried 1.7.4-- it worked, and told me to update the database which I did, but things still didn't go back to normal.

    So then I went back to 1.7.2... still no change.

  4. Alex Rabe
    Member
    Posted 3 years ago #

    Sorry, didn't checked the new version under 3.0. You need to upgrade to WP 3.1 to use the latest version

  5. lavieenrose
    Member
    Posted 3 years ago #

    The plugin says its compatible with 3.0 and up though...

    "Download Version 1.8.0

    Requires WordPress Version: 3.0 or higher
    Compatible up to: 3.2
    Last Updated: 2011-6-12 Downloads: 3,291,948"

    I always check that before downloading anything, so that I can know what to possibly expect. And this says 3.0 and up compatible.... and being a major plugin I would assume this plugin would be compatible with many versions, atleast 2.5 and higher, being that some websites may be done in particular themes that don't work properly in newer versions of WordPress.

    Or perhaps there could be a list of which versions of the plugin is compatible with a certain version of wordpress. So for example, just letting us know what the last tested version of the plugin fit the versions of wordpress.

    I'm glad the every version of the plugin is listed though.... still cant seem to fix my issue though

  6. gorky5
    Member
    Posted 3 years ago #

    I'm running 3.1.3 and also got locked out of my admin area (I'm not on Bluehost). Shame this plugin update wasn't better tested before being rolled out.

  7. Vakantie Ameland
    Member
    Posted 3 years ago #

    Running WP 3.0.1 and accessing wp-admin section is impossible after activating next-gen-gallery 1.8.0, no log messages just a 500 server error.....

  8. Alex Rabe
    Member
    Posted 3 years ago #

    As I said... I'm sorry that I forgot to raise the version number.

    ...and being a major plugin I would assume this plugin would be compatible with many versions, at least 2.5 and higher

    It's a hard work to keep compatible with older WordPress version, nobody pay for this work, so in the case you cannot upgrade WordPress anymore, don't upgrade the plugin...

  9. Alex Rabe
    Member
    Posted 3 years ago #

    Shame this plugin update wasn't better tested before being rolled out.

    I released 2. Betas and a Release candidate, do you help with testing ?

  10. lavieenrose
    Member
    Posted 3 years ago #

    ...and being a major plugin I would assume this plugin would be compatible with many versions, at least 2.5 and higher

    It's a hard work to keep compatible with older WordPress version, nobody pay for this work, so in the case you cannot upgrade WordPress anymore, don't upgrade the plugin...

    I didn't meaning keeping it compatible with every version, but maybe just keeping track of the last compatible version of NextGen-Gallery with the the last compatible versions of wordpress as they continue to be updated... or even easier, when you create new versions of NextGen-Gallery you could just have in parentheses which versions of wordpress it was successfully tested with.

    I do GREATLY appreciate you having every single past version available though. I'll have to continue to download and delete until I find one that is compatible with WordPress both 3.0.1 and "lightbox"

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic