WordPress.org

Ready to get started?Download WordPress

Forums

SI CAPTCHA Anti-Spam
The new SI Captcha update seems to be broken (24 posts)

  1. raymasa
    Member
    Posted 1 year ago #

    Hello,

    I updated the plugin, and getting the following error (on the registration page). Won't allow people to register:

    ERROR: Unreadable CAPTCHA token file

    It was working correctly before the update. Any suggestions?

    Any way to go back to the previous version, in the meantime?

    Thanks,

    Ray

    http://wordpress.org/extend/plugins/si-captcha-for-wordpress/

  2. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    Anybody who was having trouble with 2.7.6, try 2.7.6.1

    If it is not working for you, you must test for a plugin conflict.

    Here is how to troubleshoot which plugin is conflicting:
    Look on the Admin – Plugins – menu.
    Temporarily deactivate (not uninstall) all your other plugins. Leave this one still activated.
    Does it work now? If yes, Activate the other plugins one by one to determine which one conflicts. Which one was it?

    If you still have trouble I need to know:

    What is the error or problem?
    What steps to reproduce the problem?
    Which form is it doing that on? login, comment, registration, or lostpassword
    What version of WordPress?
    Do you have multi-site or BuddyPress installed?
    What theme?
    Are any other plugins causing it? (deactivate all the others to see if the problem goes away)

    Yes you can go back to a previous version:
    FTP to the server and delete this folder: /si-captcha-for-wordpress/
    the folder is found in /wp-content/plugins/

    download
    http://downloads.wordpress.org/plugin/si-captcha-for-wordpress.2.7.4.zip
    Unzip the file on your computer.
    Use a FTP program such as FileZilla to connect to your web server .
    FTP File Transfer this folder this folder: /si-captcha-for-wordpress/ from your downloaded files to the folder on your server: /wp-content/plugins/
    On the plugins admin page, find SI CAPTCHA and click “Activate”. The plugin will now be activated.

  3. zamba
    Member
    Posted 1 year ago #

    I've been using 2.7.4 without issue until the last WP upgrade (3.5). I have NOT upgraded yet (now on 3.4.2) but did upgrade SI Captcha to the latest version (2.7.6.1) . I am running multisite under a single domain with 28 sub-blogs in folders; the theme is lifestyle on Genesis. The immediate result was that ALL attempted comments gave the ERROR Possible Spam Bot message and failed.

    I restored 2.7.4 and all appeared well again. Hope this is of some use, I'll follow this thread and inform of any developments.

    Tony

  4. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    Tony,

    Just now I tested on multi-site with subfolders on WP 3.5 Twenty Twelve theme. I installed the plugin like this Network Admin < Plugins < Add New
    In stall SI CAPTCHA Anti-Spam < Network Activate

    I could not duplicate the problem, I was able to post comments.

    If it is not working for you, you must test for a plugin conflict.
    Install the latest version (2.7.6.1)

    Here is how to troubleshoot which plugin is conflicting:
    Look on the Admin – Plugins – menu.
    Temporarily deactivate (not uninstall) all your other plugins. Leave this one still activated.
    Does it work now? If yes, Activate the other plugins one by one to determine which one conflicts. Which one was it?

    Did that work?

  5. Sergei
    Member
    Posted 1 year ago #

    Hi, guys. Have just had the same problem. Problem was solved when I manually created TEMP directory in wp-content/plugins/si-captcha-for-wordpress/captcha and set permissions to 777. Hope it helps.

  6. zamba
    Member
    Posted 1 year ago #

    Hi Mike,
    I'm going to test the new versions on a separate mirror set-up (structure only, the live site is too big to mirror content)to check whether upgrading to 3.5 makes any difference with the new SI Captcha version.
    @Sergei, I do have a temp directory in my current 2.7.4 captcha directory, but it's 755. I'll try your solution when testing, although it may compromise security a little.
    Merry Christmas to all!

  7. zamba
    Member
    Posted 1 year ago #

    I've now tested the latest version on WP 3.5 and have no problem in commenting. This was on a test blog with all the plugins of the main blog and on the same server. So at first site this would appear to be connected with the 3.5/2.7.6.1 upgrades.

    As I'm not yet ready to upgrade the main site I'll wait to move to the latest version of SI Captcha until we're happy 3.5 hasn't any nasty surprises for us!

    Thanks for your help, guys, and if I run into any more issues I'll come back to the forum.

  8. MickeyRoush
    Member
    Posted 1 year ago #

    I'm also getting the "ERROR Possible Spam Bot" message. I won't be able to determine if it's a plugin conflict just yet. But the temp directory is creating the php file, so I don't believe it's a permission issue. I'm just deactivating the plugin for right now.

  9. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    Try the new version 2.7.6.2

  10. MickeyRoush
    Member
    Posted 1 year ago #

    I forgot to mention. I don't have a problem with the login, it's the comment section that's causing the messages. No one can comment. I just disabled it for the comment section.

  11. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    If it is not working for you, please test for a plugin conflict.
    But first, upgrade to the latest version.

    This should only take a few minutes.
    Here is how to troubleshoot which plugin is conflicting:
    Look on the Admin – Plugins – menu.
    Temporarily deactivate (not uninstall) all your other plugins. Leave this one still activated.
    Does it work now? If yes, activate the other plugins one by one to determine which one conflicts. Test after activating each other plugin. Which one was it?

    Did that work?

  12. brevardelite
    Member
    Posted 1 year ago #

    Mike,

    I upgraded to the latest version today and now I can't login to my page. I was getting an error message that read as follows,

    ERROR: Possible Spam Bot

    Now it is giving me an error that says:

    ERROR: Unreadable CAPTCHA token file

    I don't know how to look at anything because I can't even enter the dashboard. Please help! Thanks, JB

  13. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    If you cannot get into your site you can manually remove the plugin:
    FTP to the server and delete this folder: /si-captcha-for-wordpress/
    the folder is found in /wp-content/plugins/

    I will go check the code right now to see if I missed anything.

    Mike

  14. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    JB, are you using JetPack or any sharing plugins? Jetpack and other sharing plugins can cause problems with this plugin.

    I did find a small coding mistake I will fix right now but it would not cause "ERROR: Unreadable CAPTCHA token file"
    Jetpack and other sharing plugins can cause that error

  15. doromonoh
    Member
    Posted 1 year ago #

    I had the same problem but I think version 2.7.6.4 fixed the problem. Thanks for fixing it.

  16. brevardelite
    Member
    Posted 1 year ago #

    Hey Mike,

    That did the trick. Thanks for the help!

  17. brevardelite
    Member
    Posted 1 year ago #

    By the way, no I am not using JetPack or any sharing plugins.

  18. fu-sin
    Member
    Posted 1 year ago #

    Hey Mike,
    I have the same error with version 2.7.6.4 and WordPress 3.4.1.
    Problem was solved by setting permissions to 777 for existing TEMP directory in wp-content/plugins/si-captcha-for-wordpress/captcha.

  19. nicodemusy2k
    Member
    Posted 1 year ago #

    Have the same problem with giving me ERROR: Unreadable CAPTCHA token file at the Login Form.

    To chmod the folder to 777 didn't help.

    Had to delete it on filelevel out of the plugins folder since it didn't let me login to deactivate it.

    Latest versions of WP as well as from Plugin.

  20. JackNorrisRD
    Member
    Posted 1 year ago #

    In the 2.7.7 version, I had to increase the permissions on the captcha/cache file to 777. In the past, I've had to do that for the /temp file to get it to work, but the /temp file is no longer there (replaced by the /cache, I assume?).

  21. Mike Challis
    Member
    Plugin Author

    Posted 1 year ago #

    yes, it is /cache/ now

  22. thailon
    Member
    Posted 1 year ago #

    Hello there,

    I set the permissions but it did not help. I wanted to download new version 2.7.6.2, but only version 2.7.6.1 is available on http://wordpress.org/plugins/si-captcha-for-wordpress/. Any suggestions ?

  23. stamy74
    Member
    Posted 12 months ago #

    I created a temp folder (didn't exist) and set the permissions to 777.
    Problem remained.
    I changed also the permissions on the cache folder to 777 and the problem was solved!

  24. KeithLefthander
    Member
    Posted 9 months ago #

    Recently updated to 2.7.7.3 and started getting the same error
    ERROR: Unreadable CAPTCHA token file

    Changed the permissions on
    /wp-content/plugins/si-captcha-for-wordpress/captcha to 777
    and it fixed it.
    Looks like upgrading the plugin changes the pernmission on that folder back to 755? need to remember to change it to 777 again whenever the plugin is updated, or is this something that Mike can fix?

    BTW - thanks Mike for the plugin!
    Keith

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.