WordPress.org

Ready to get started?Download WordPress

Forums

Google Site Verification Plugin
The necessary verification token could not be found on your site. (9 posts)

  1. Odolyte
    Member
    Posted 3 years ago #

    When trying to create the link we get :
    "The necessary verification token could not be found on your site."

  2. herozup
    Member
    Posted 3 years ago #

    Same error for me

    Verifying your blog... failed, due to an error:
    
    Error calling https://www.googleapis.com/siteVerification/v1/webResource?verificationMethod=META&alt=json: (400) The necessary verification token could not be found on your site.

    Trying to use the plugin on http://chiotsrun.com

  3. kbm
    Member
    Plugin Author

    Posted 3 years ago #

    Which WordPress theme are you using? Has it been customized at all?

  4. herozup
    Member
    Posted 3 years ago #

    Hi kbm,

    Custom theme that is highly customized. What do I need to add to the theme?

  5. Vid Luther
    Member
    Posted 3 years ago #

    We're seeing this across our sites as well, most of them are custom themes, some are off the shelf from themeforest or Woo.

  6. Vid Luther
    Member
    Posted 3 years ago #

    Never mind, just saw your updated FAQ and the notice about the caching. Once I cleared that up, things worked.

    Any chance you'll give people the option of using the various verification methods? The API allows file, meta and analytics, since some GA plugins already have the analytics verification going, could you perhaps give that option? or allow the option to use the FILE verification, the file verification would probably be easiest to implement, though probably insecure in some environments, but it would take care of the caching issue :).

    Or just put a note up saying CLEAR YO CACHE FOO! right on the "Start Verification" thing.

    In our case, it was the static nginx cache that caused the issue, which most of our clients would not be able to clear themselves.

  7. herozup
    Member
    Posted 3 years ago #

    Yep... WP Super Cache enabled here too. Deleted cache, verification complete. Thanks!

  8. kbm
    Member
    Plugin Author

    Posted 3 years ago #

    herozup: Make sure that your header.php file makes a PHP call to wp_head() somewhere inside the <head> tag.

    zippykid: I'm glad to hear that clearing the cache worked. I added a reminder for clearing the cache directly in the verification UI.

    I appreciate your suggestions! You're right that both Meta and File verification methods are prone to their own unique classes of issues (caching layers, filesystem permissions, etc.) Right now we are planning on sticking with Meta, but we will monitor the success rates and forum activity to see if we need to supplement our approach with additional contingency methods.

  9. ernstfoyn
    Member
    Posted 2 years ago #

    I have the same problem. Have deactivated caching and this code is in the header <?php wp_head(); ?> Is there something else I can try out? I run a customized version of motionpicture from http://www.obox-design.com on my site http://www.babusjka.no

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic