WordPress.org

Ready to get started?Download WordPress

Forums

WP to Twitter
The last 9 characters of my tweet gets deleted when posted to twitter (5 posts)

  1. fabtigger
    Member
    Posted 4 months ago #

    Hello.

    Thanks for an amazing plugin. It works brilliantly. However there is a strange quirk that I would like to rectify.

    I use the 'Custom Twitter Post' box when posting my messages to twitter. I will generally use the full 140 characters that are on display, however when I publish the post only roughly 131 characters get posted on twitter? I've looked through the settings but can't figure what I'm doing wrong as it doesn't appear that anyone else has this issue.

    Can you help? What other information do you need?

    https://wordpress.org/plugins/wp-to-twitter/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 4 months ago #

    Are you using any special characters, such as characters with umlauts or diacritical marks?

    If so, and you don't have the PHP Normalizer class installed in your server's PHP build, then the character counting that WP to Twitter does won't always match the count provided by JavaScript. JS is counting letter insertions, which will match the count you get from Normalized text, but if that class isn't available, the count will only be approximate.

    Another possibility is if you're using uncounted template tags in your custom Tweet; not all tags are known values at the time you're writing your post (such as #tags#), so they are not counted, and you have to accommodate for them yourself when writing a custom Tweet.

  3. Joe Dolson
    Member
    Plugin Author

    Posted 4 months ago #

    Hi - I got your support request via email, but I can't reply to it, because the admin email address I received from your server is a no-reply address.

  4. fabtigger
    Member
    Posted 4 months ago #

    Just sent you a message through your website :-)

  5. Joe Dolson
    Member
    Plugin Author

    Posted 4 months ago #

    Doh. That form is having some issues and needs some work...I didn't get the message. You can just send another support request with a usable email in the body of the message.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.