WordPress.org

Ready to get started?Download WordPress

Forums

The .htaccess file and server performance... a work around for permalinks (3 posts)

  1. ryanc
    Member
    Posted 8 years ago #

    I've been posting about my issue for a couple of days now and you guys have been a huge help, but my problem still remains.

    Just in case you aren't familiar, here is some background:
    I run http://www.jalopyjournal.com and it gets around 1.7 million page views a week using wordpress 2.0. If I use permalinks of ANY kind, the rewrites going on through the .htaccess file eventually bring my server down to its knees as it sends server load upto the high 30s. However, if I turn purmalinks off and use the default WP settings, I have ZERO issues with server load. So, .htaccess is the issue.

    Obviously, I would REALLY like to have the permalink option on my pages. Is there any chance of this being improved in the future? Are there any work arounds?

    Thanks a ton,

    Ryan C.

  2. niziol
    Member
    Posted 8 years ago #

    Hey Ryan,

    I did a little searching, I never even thought about .htaccess's affect on server performance, so I did a little google search and found this thread on WebMasterWorld, it discusses a site that has high traffic and is completely served via PHP/MySQL (like what WordPress does), maybe it might be of some help for you.

    Not being a systems admin, but from what I understand of how .htaccess works, I'm not sure there is anything WordPress can do about it, WP 2.0+ just generates 3 rules for its use and the rest is handled internally by WordPress. Are the WP rules the only rules you have in your .htaccess?

    I hope this issue gets figured out for you soon!

    Good luck,
    Michael.

  3. ryanc
    Member
    Posted 8 years ago #

    That's interesting... It sounds like that guy can get away with all kinds of rewrites. Here is the entire contents of my .htaccess if I have friendly URLs on:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    # Added 2-1-2005 kw
    RewriteEngine On
    RewriteCond %{HTTP_REFERER} !^http://jalopyjournal.com.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.jalopyjournal.com.*$ [NC]
    RewriteRule .*[Jj][Pp][Gg]$|.*[Gg][Ii][Ff]$ http://jalopyjournal.com/index.html
    # end added section

    As it currently runs, if I turn on friendly URLs for 5 minutes, its brings my server down. I realize that I get a ton of traffic, but the results is certainly unexpected.

    Thanks again for all of your help.

Topic Closed

This topic has been closed to new replies.

About this Topic