WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] the hello world post link created by install not viewable (16 posts)

  1. larry@zeropoint.com
    Member
    Posted 3 years ago #

    The post is there and can be edited in admin, but the link to the post is invalid ( http://www.myblog.com/?p=1 ) on the blog start page.

    This is a new installation so I'm sure something is not set up properly.

    Any ideas on where to start looking? I've spent a long time on this...

    Thank-you for your help,

    Larry

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Is this a local installation?

  3. larry@zeropoint.com
    Member
    Posted 3 years ago #

    It's on a remote server (deployment). My first installation.

    It's Suse linux 11.2, and I use ssh to remotely manage it.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    I think there might be an issue with the server configuration. Can you post a link to the site?

  5. larry@zeropoint.com
    Member
    Posted 3 years ago #

    I'll check, in the mean time I created a page in wp-admin, and when I hit the 'view' link it will not show... same issue it appears.

  6. larry@zeropoint.com
    Member
    Posted 3 years ago #

  7. esmi
    Forum Moderator
    Posted 3 years ago #

    Definitely something very wrong here. I also noticed that your login page has no CSS (the stylesheets are 404s). Was the site moved post-install? Did the site url change at any point? Have you spoken to your hosts (or are you your own host)?

  8. larry@zeropoint.com
    Member
    Posted 3 years ago #

    I'm hosting this on my own server. I did have an issue with directory permissions which I think I straightened out. Are there missing files? or could it be another permissions issue?

  9. larry@zeropoint.com
    Member
    Posted 3 years ago #

    Should I just reinstall? Are there any issues that could cause?

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    I'm just about to log off for a while but before I do I'll see if I can get some of the other forum regulars with more server admin experience to drop in and lend a hand.

  11. larry@zeropoint.com
    Member
    Posted 3 years ago #

    Thanks! I reinstalled from the server side and copied everything in to the directory just to be sure that permissions and all were correct.
    Still the same problems..

    At least I'm more confident that things ought to work...

  12. Mark
    Member
    Posted 3 years ago #

    Have you checked to see if any .htaccess files are overriding URLs? Maybe there's such a file in your domain root dir?

  13. EMG
    Forum Volunteer
    Posted 3 years ago #

    I was about to suggest the same question.

    .htaccess issues can cause problems with permalinks and just any links in general and that includes image links and stylesheets.

    Do you have an old .htaccess file from a previous installation or anything whose settings might be overriding what the default settings would be?

  14. Gisha James
    Member
    Posted 3 years ago #

    Not sure whether it will work, though worth - giving a try:

    wp-admin --> Settings ---> Permalinks --> click on Save changes

  15. larry@zeropoint.com
    Member
    Posted 3 years ago #

    Apache mod_rewrite was not working. I now have htaccess rewriting working properly, so I made another step in the right direction with your help.

    However, nothing appears different.

    Other than the lines inserted by wordpress are there any other lines required in the .htaccess file? If WordPress can access and rewrite the .htaccess file is there any other thing that can cause these 404 errors?

    The current .htaccess file contains

    # BEGIN WordPress

    # END WordPress

    and that's all.

  16. larry@zeropoint.com
    Member
    Posted 3 years ago #

    FIXED IT!!

    I have an intelligent router that was filtering out requests that start with '/?'.. That did it!

    Now I can proceed.. I appreciate this forum and all your comments, I was able to fix install issues that would have created other problems and it was very appreciated.

    Thanks!
    Larry.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.