WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] The Google Sitemaps Blank Page Problem (6 posts)

  1. Keilya
    Member
    Posted 6 years ago #

    Hello

    I've been having problems with Google Sitemaps ever since the recent upgrade to 2.2. I'm currently running on WP 2.2.1.

    With Google Sitemaps 2.7.1, I am able to activate the plugin. But..

    1. I get a blank page when I hit the "Post" or "Save" buttons.
    2. On clicking "Build Sitemaps" under Options>>Sitemap, I don't get a successful ping to Google.

    I've researched and some solutions were provided.

    1. Applying this patch: http://trac.wordpress.org/ticket/2463
    The patch itself is a problem as it no longer works. There isn't a file called template-functions-links.php anymore. Is there anyway I can get around this?

    2. Increasing memory and time limits:
    - Try to increase the memory limit on the sitemap options page (start by "4M" and raise the value if it doesn't help).
    - Try to increase the time limit on the sitemap options page (start by "20" and raise the value if it doesn't help).

    Question is how do I go about doing them? If it's in the php.ini file, here are some current stats:

    ;;;;;;;;;;;;;;;;;;;
    ; Resource Limits ;
    ;;;;;;;;;;;;;;;;;;;

    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    memory_limit = 8M ; Maximum amount of memory a script may consume (8MB)

    3. Clearing the Google Sitemaps plugin log: http://wordpress.org/support/topic/92782?replies=24

    Again, where is the log and how do I clear it?

    With that single problem and so many vague solutions (not evryone is a PHP ninja.), I tried downloading the beta version of the plugin(3.0b8). I deleted the 2.7.1 version from my server and uploaded 3.0b8. This time I can't even activate it:

    1. My plugin page does not finish loading. It stops at this line: "Plugins extend and expand the functionality of WordPress. Once a plugin is installed, you may activate it or deactivate it here." and nothing loads below it.

    I know this is technically not a WP support question. But I've ran out of avenues and ideas. >.< If anyone can solve either the problem with 2.7.1 or 3.0b8, I'll be more than happy to cease pursuing the other.

    Thank you for reading.

  2. Keilya
    Member
    Posted 6 years ago #

    Anyone? I would really like to try this solution if only I knew which lines to edit! >.<

    2. Increasing memory and time limits:
    - Try to increase the memory limit on the sitemap options page (start by "4M" and raise the value if it doesn't help).
    - Try to increase the time limit on the sitemap options page (start by "20" and raise the value if it doesn't help).

  3. drmiketemp
    Member
    Posted 6 years ago #

    Oh, dang. We've discussed this before and I'm on a locked down terminal and can't do a search. It's one line that you edit.

    have you searched teh forums? "sitemap blank"?

  4. Keilya
    Member
    Posted 6 years ago #

    Ahh dang! Of course I had searched prior to this but I had the word, "Google" included in my search. Using your keywords gave me a complete different set of results and I managed to get the 2.7.1 version running with the fix mentioned in this thread: http://wordpress.org/support/topic/80347?replies=6

    THANK YOU!

  5. Keilya
    Member
    Posted 6 years ago #

    Ahh I spoke too soon. I could rebuild my sitemap but whenever I click on "Post" or "Save" I still get a blank page. I've inserted these 2 lines(as indicated in the fix):

    ini_set("memory_limit","64M");
    set_time_limit(0);

    EXACTLY above this line in sitemap.php:

    //Pressed Button: Rebuild Sitemap
    if(!empty($_POST["doRebuild"])) {
    $msg = sm_buildSitemap();

    Please tell me if I'm doing anything wrong. >.<

  6. Keilya
    Member
    Posted 6 years ago #

    Just like to give a close to this topic. It was solved by increasing the memory via editing wp-config.php

    Add this:

    //Allow more memory.
    @ini_set("memory_limit","16M");

    before this:

    /* That's all, stop editing! Happy blogging. */

    Much thanks to Arnee for looking into it!

Topic Closed

This topic has been closed to new replies.

About this Topic