WordPress.org

Ready to get started?Download WordPress

Forums

the feeds at the bottom of the page don't do anything (8 posts)

  1. annekirrin
    Member
    Posted 8 years ago #

    in the footer there are two rss links. these links seem to do nothing. are they not supposed to be my syndication feeds to anyone who wants them? How d I get them working?

    any help will be appreciated.

  2. Chris_K
    Member
    Posted 8 years ago #

    Have a link to your blog?

    What happens when you click the feed urls?

  3. eawilson
    Member
    Posted 8 years ago #

    Yes I have the same problem with a new blog that I started up after the latest WordPress update.
    My site is here. The relevant code from the footer.php file in my current theme is:
    <a href="<?php bloginfo('rss2_url'); ?>"><img src="<?php bloginfo('stylesheet_directory'); ?>/images/buttons/rss.png" alt="RSS" /></a>
    <a href="<?php echo get_settings('siteurl'); ?>/wp-commentsrss2.php"><img src="<?php bloginfo('stylesheet_directory'); ?>/images/buttons/rss_comments.png" alt="RSS Comments" /></a>

    The problem persists even with the generic theme in WP. When I click on the link in Firefox, I get a blank page. When I open the RSS links in Safari, I get the following message

    Too many redirects occurred trying to open “http://canadianintellectuals.net/blog/?feed=rss2”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page.

    Any help would be appreciated... I am very new to .php and WordPress in general.

  4. sayshea
    Member
    Posted 8 years ago #

    I am having a similar problem, here:
    http://www.sayshea.com/blog/

    Still trying to wrap my brain around the whole RSS thing so maybe I still haven't set something up that I should have. When I click on the RSS feed in the footer, a box pops up that says "Firefox doesn't know how to open this address, because the protocal (feed) isn't associated with any program."

    I am still searching through the forum though, so will post if I find the answer somewhere in here.

  5. eawilson
    Member
    Posted 8 years ago #

    sayshea,

    Looks fine. I couldn't find a problem with your RSS feed. It reads fine in my RSS aggregator and in Safari, which is RSS compatible.

    You need to remove the "feed" from the link in your footer, before anything is accessible through Firefox. Read this post to find out more.
    Unlike your feed, which is viewable, my feed seems to be dead or altogether non-existent.

    eawilson

  6. sayshea
    Member
    Posted 8 years ago #

    Ok, I downloaded the K2 theme and copied the links from the footer and replace the ones in my theme (which was originally the default theme).

    I did this before I saw your post! eawilson is right, the difference is the "feed" part in the link.

    This is the code that works for me:

    ">RSS Entries
    | ">RSS Comments

  7. sayshea
    Member
    Posted 8 years ago #

    Let's try this again:

    <a>">RSS Entries</a>
    | <a>">RSS Comments</a>

  8. sayshea
    Member
    Posted 8 years ago #

    Well ok...


    <a href="<?php bloginfo('rss2_url'); ?>">RSS Entries</a>
    | <a href="<?php bloginfo('comments_rss2_url'); ?>">RSS Comments</a>

Topic Closed

This topic has been closed to new replies.

About this Topic