WordPress.org

Ready to get started?Download WordPress

Forums

the evil "We're having a little trouble" strike (9 posts)

  1. mizkit
    Member
    Posted 9 years ago #

    Ok, I've gone through approximately a jillion postings about this problem, and tried several solutions, but I still donno what I'm doing wrong. Trying to install WordPress, getting the following error:
    We're having a little trouble selecting the proper database for WordPress.
    Are you sure it exists?
    Your database name is currently specified as mizkit_wordpress. Is this correct?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?
    I'm sure it exists; if I go to my control panel I see it there, all existy-like. My other databases are named mizkit_databasename, so I'm confident I've got the name right. I'm willing to accept that I can't remember my own password, but there's no indication in this message that it's the password I've got wrong, so I don't *think* that's it. Am I wrong? Help! So confused!
    I've checked my phpMyAdmin (which I'd never seen before!) and it claims there is indeed a mizkit_wordpress database, which has no tables in it. That doesn't mean a darn thing to me, but I saw it come up in other questions about this same problem, so I thought I'd mention it. :)
    Any insights would be appreciated!
    -Catie

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    When you log into phpmyadmin, the username and password will be the ones you need for wp-config.php
    Again, in phpmyadmin, look at the letters at the top screenshot here:
    http://www.mfr.f2s.com/phpmyadmin/
    see the podz@localhost ?
    The bit following the @ should be the last part of wp-config.

  3. mizkit
    Member
    Posted 9 years ago #

    Right... so my wp-config.php should read:
    // ** MySQL settings ** //
    define('DB_NAME', 'mizkit_wordpress'); // The name of the database
    define('DB_USER', 'mizkit_catie'); // Your MySQL username
    define('DB_PASSWORD', '(password)'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to
    ...right? Am I understanding you correctly, or am I missing some small esoteric but important step in this? For what it's worth, this is what I have now, and 'localhost' is what that text area at the top says: MySQL 4.0.20-standard running on localhost as mizkit@localhost
    -Catie, feeling foolish :)

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    You aren't foolish ! )
    That info looks right...is your username correct though ? That would be my guess. Try 'mizkit' ?

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    On messenger ?
    MSN: podz2097@hotmail.com
    AIM: podz2097

  6. mizkit
    Member
    Posted 9 years ago #

    THe username's correct. If I change it, I get this error:
    Error establishing a database connection! This probably means that the connection information in your wp-config.php file is incorrect. Double check it and try again.
    Are you sure you have the correct user/password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    Now, I *am* supposed to have the password in there in plain text, right? I haven't got that wrong?
    -Catie

  7. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Plain text is good.
    Hmm... check your cpanel: Does that say anything at all about a 'connection string' for mysql ?

  8. TechGnome
    Moderator
    Posted 9 years ago #

    Something that I've seen as a problem in the past by others is not granting the user enough access to the DB.
    Don't know if that's the problem, but it's worth a look.
    TG

  9. Anonymous
    Unregistered
    Posted 9 years ago #

    Catie, I was having the same problem as you... until I realized that I hadn't added a user to the sql db. What a stupid oversight on my part!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.