WordPress.org

Ready to get started?Download WordPress

Forums

Events Made Easy
[resolved] The contents of the "details" link is replaces slider in the graphene theme (12 posts)

  1. Greybox
    Member
    Posted 8 months ago #

    We use Graphene theme. For some reason the contents of the "details" link on the Google map replaces all slider contents.

    http://niftynude.org/locations/4/templeton-pool/

    http://wordpress.org/plugins/events-made-easy/

  2. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    It doesn't do that here, but I don't have the slider on every page, just the home page. I don't know the graphene theme, so how did you activate the slider on all pages, so I may test some more?

  3. Greybox
    Member
    Posted 8 months ago #

    Franky: Thank you for responding so quickly!

    I used a child theme. I followed the instructions from this article:
    http://www.prasannasp.net/graphene-slider-on-other-pages-modifying-theme-functions-using-a-child-theme/

  4. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    I just tried it with those instructions and it seems to be working just fine, so I'm guessing you have another thing causing interference.

  5. Greybox
    Member
    Posted 8 months ago #

    My Graphene version is 1.9.2. (I assume you have same version).

    Did you try with "Move slider to bottom of page" enabled in Graphene General Options?

  6. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    Yes to both questions.

  7. Greybox
    Member
    Posted 8 months ago #

    That was my hope because I noticed everything works fine for me if I uncheck "Move slider to bottom of page" in Graphene General Options. But if the slider is at the bottom (which I need), the contents of your plugin map details link is replaces the contents of Graphene slider (except the header of the slider post).

    I also tried disabling the active plugins one by one - didn't help.
    It seems to be a conflict between your plugin and Graphene theme.

    Is it possible to get a clue via "inspect element" debugging tool?

  8. Greybox
    Member
    Posted 8 months ago #

    I have just found something interesting:

    If I select "Thumbnail and excerpt" in Slider display style, General Options in Graphene Theme Options, everything shows correctly. The problem reveals itself when I select "Full post content" in Slider display style (which would be my preference). Can you reproduce same thing?

  9. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    When clicking on the location details, you arrive at the special events page where EME replaces the content with the one being asked for (event details, location details, ...).
    So maybe there's an issue there. I need to check that.

  10. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    Ok, I think I got it.
    Please try changing line 678 in eme_events.php from

    if (count($wp_current_filter)>1 && end($wp_current_filter)=='the_content' && $eme_count_arr['the_content']>1) {

    to

    if ((count($wp_current_filter)>1 && end($wp_current_filter)=='the_content') || $eme_count_arr['the_content']>1) {

    If it works ok (it should), I'll add an option to make the_content filter loop protection less or more strict, so you can then change it with just an EME setting.

  11. Greybox
    Member
    Posted 8 months ago #

    It was actually line 656 for me.
    Updated, works fine. Great job!! Thank you!! Thank you!! Thank you!!

  12. Franky
    Member
    Plugin Author

    Posted 8 months ago #

    Thanks. The next version will have a setting for this, the default will be

    if (count($wp_current_filter)>1 && end($wp_current_filter)=='the_content') {

    which should also work for you.

Reply

You must log in to post.

About this Plugin

About this Topic