WordPress.org

Ready to get started?Download WordPress

Forums

The classic "Unable to locate WordPress Content directory (wp-content)" error (3 posts)

  1. twpu
    Member
    Posted 2 years ago #

    Hello.

    I've been using WP for...2 days. Everything went fine under Windows. But when I tried to isntall the same zipped WordPress, I encountered this error. I am running Mandriva Linux 10.0, Xampp 1.7.7 for Linux, and the ftp program is PROFTPd. I fixed it but would like somebody to explain what I just did and WHY this hapened in the first place.

    I fixed the linux problem thanks to this post:

    http://wordpress.org/support/topic/unable-to-locate-wordpress-content-directory-wp-content-11?replies=21

    I used this code to fix the problem:

    define('FS_METHOD', 'ftpsockets');
    define('FTP_BASE', '/opt/htdocs/wordpress');

    Also, why does WordPress ask for ftp connection data everytime I have to update/install something. I know it's because it ftp-uploads files into my local server, but why does this happen only under the Linux server?

    Thanks

  2. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 2 years ago #

  3. twpu
    Member
    Posted 2 years ago #

    Thank you for your answer. I see it is a permissions issue.I set it to nobody and nogroup. Seems to work fine now.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic