WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] The case of the overly-slim Dashboard (14 posts)

  1. Chris_K
    Member
    Posted 8 years ago #

    Every now and then, with no apparent rhyme nor reason, I get a very -- nay, overly -- slim Dashboard page.

    I submit Exhibit A.

    I find myself at a loss of how to explain this.

    Looking at the apache logs, nothing in error logs and all http 200's in the access logs. So apache seems hunky-dory.

    The only thing that seems related is I upped php.ini memory to 32MB (from 12) thursday night. But I'm struggling with why more memory would cause it to SOMETIMES break.

    Thoughts?

  2. Michael Bishop

    Posted 8 years ago #

    404 for exhibit A

  3. Chris_K
    Member
    Posted 8 years ago #

    Apologies. Is there now.

  4. Chris_K
    Member
    Posted 8 years ago #

    To confuse things, I noticed that "Dashboard" displays as shown in exhibit A on one machine. From another machine, things appeared fine. (And yes, I've cleared cache and forced reloads on both). Both using FF 1.5x.

    Logging out of the Admin and then logging back in magically fixed everything. Cookie issue of some sort I suppose?

  5. billh
    Member
    Posted 8 years ago #

    Does your host allow includes from other sites? Most of the dashboard is from the WP development blog. A co-worker of mine gets the same thing on his dashboard; turns out his host doesn't allow off-site includes.

  6. Chris_K
    Member
    Posted 8 years ago #

    Yep, my host (aka me!) allows 'em. :-)

    After some more goofing around today, only one browser on one machine (out of too many on too many) seems to actually have this problem. And logging out and back in fixes it every time. Dunno what I did, or how I did it... but guess that'll be the work-around for now.

    Honestly, I dunno how long it's been an issue as I tend to avoid the Dashboard -- I haven't hacked out the "promotional" feeds yet since the 2.0.2 upgrade.

  7. Chris_K
    Member
    Posted 8 years ago #

    Now happens on all my browsers, all my machines. Not the end of the world, but definitely wandering into the "very annoying" realm.

    I can confirm it isn't a WP caching issue. I've disabled the 2.x caching (and confirmed that no files are landing in cache). Same thing. I don't run any other caching plugins.

    Logging off and back in fixes it everytime. once. If I then leave dashboard and come back (say, by clicking on Plugins for instance), back to the "nothing" version (see pic in first post).

    Looking at apache error_logs, nothing shows up. All the access_log entries are 200's.

    Using Firefox's Javascript console, I get a few CSS type issues...

    Error: Unknown property 'zoom'. Declaration dropped.
    Source File: http://www.solo-technology.com/blog/wp-admin/wp-admin.css?version=2.0.2
    Line: 605
    ------------
    Error: Unknown property '-khtml-opacity'. Declaration dropped.
    Source File: http://www.solo-technology.com/blog/wp-admin/wp-admin.css?version=2.0.2
    Line: 922
    -----------
    Error: Unknown property 'filter'. Declaration dropped.
    Source File: http://www.solo-technology.com/blog/wp-admin/wp-admin.css?version=2.0.2
    Line: 923

    Related maybe?

  8. Serenity
    Member
    Posted 8 years ago #

    Thanks for your reply handy!
    since you have treid more then me ill try to reply here!
    http://wordpress.org/support/topic/66967?replies=2

    even when i go to http://www.myblog.com/blog/wp-admin/post.php or other wp-admin/pages.php still nothing appear!

    i really don't know what is going on :s

  9. Chris_K
    Member
    Posted 8 years ago #

    Closing in on it, maybe.

    When first logging in, I get a url like
    http://www.solo-technology.com/blog/wp-admin/

    That url works every time.

    When I'm elsewhere in the admin stuff, and click on the "Dashboard" link, I go to
    http://www.solo-technology.com/blog/wp-admin/admin.php?page=index.php
    See Exhibit A in the first post. (no workie)

    If I shorten that link to end at wp-admin it works. So logging out and back in isn't necessary.

    So... does that mean anything to anyone?

  10. rnoble
    Member
    Posted 8 years ago #

    Well, HandySolo, to me it means I have my dashboard back. I just shortened the URL like you did in the post and I am back in the good graces of the WordPress admin panel. Don't know why, or actually how I got the longer URL in the first place, but - whatever - it works. Thanks to you and others for the help!

  11. Libertus
    Member
    Posted 8 years ago #

    If you have trouble with the external RSS feeds to the Dashboard, they can be disabled by commenting out line 5 of wp-admin/index.php.

    //require_once(... ... 'rss-functions.php)

  12. ringmaster
    Member
    Posted 8 years ago #

    For me, it would be a question of what plugin you have installed that is causing your admin menu to use the link with ?page=index.php instead of the default link. Figure that out, and I think you've solved your issue.

    Note that in a standard install of 2.0.2 there shouldn't be a link in the admin to the long URL that you've provided, which is why I assume that there is a plugin installed that is causing this to happen. Perhaps something that is supposed to enhance your dashboard somehow, or add new submenus under Dashboard?

  13. Chris_K
    Member
    Posted 8 years ago #

    @libertus - I should've mentioned, I've removed the feeds in the past with no difference.

    @ringmaster - Hadn't thought to go that deep yet. But alas, no dice. I disabled ALL plugins, even redid permalinks just for grins, but still get that goofy ?page=index.php thing.

    Which is a bummer, I sure thought you were on to something there!

    My dashboard has been re-extracted from wp2.0.2 distribution in the past to undo my removal of RSS feeds (wanted to be sure that didn't CAUSE this problem). I don't have anything running to change admin stuff (I used to have the Tiger style thing running, but have long since disabled it and I think it was just CSS).

  14. Chris_K
    Member
    Posted 7 years ago #

    ... resolved after reading: http://wordpress.org/support/topic/100366?replies=5#post-498478

    I had ye olde' empty index.php in /plugins. Renamed it to index.html and suddenly my dashboard functions again. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic