WordPress.org

Ready to get started?Download WordPress

Forums

The case of the disappearing posts... (2 posts)

  1. jonthejester
    Member
    Posted 9 years ago #

    Forgive me for the ambiguous title, but that's the only way I can describe this problem I have. If you check out http://plainculture.com, you'll see that there's a yellow box that says 'Archives'. And to the explanation of my problem, and the first part unfortunately, mind you:

    I've been adding/removing plugins, and somehow the listing of recent posts from a few categories (via 'query_posts') all of a sudden disappeared. I tried disabling all plugins, that didn't work. If I try specifying one category ('query_posts('cat=3')'), it'll think I'm asking for that category and change the whole look of the page. If I even just remove query_posts(), that doesn't work either. Here's the code that's currently there at this point:

    <h2>Recent Updates</h2>
    <div id="recent-updates">

    <?php /* This variable is for alternating comment background */
    $oddpost = ' alt'; ?>

    <?php // query_posts('showposts=7'); ?>
    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>

    <div class="post<?php echo $oddpost; ?>">
    <h3><a href="<?php the_permalink(); ?>" rel="bookmark"><?php if((empty($post->post_title))) { echo '<em>[No Title]</em> '; } else { the_title(); } ?></a></h3>
    <h4><?php the_author_posts_link(); ?></h4>
    <?php if(!(in_category(25))) { the_excerpt(); } ?>
    <p class="meta"><?php the_category(', '); ?> &mdash; <?php the_time('n/j/Y'); ?><?php if(!(in_category(25))) { ?> &mdash; <?php comments_popup_link('No Comments (yet)', '1 New Comment!', '% Comments!'); } ?></p>
    </div>

    <?php /* Changes every other comment to a different class */
    if (' alt' == $oddpost) $oddpost = '';
    else $oddpost = ' alt';
    ?>

    <?php endwhile; endif; ?>

    <div id="archives-link"><a href="/archives">Archives</a></div>
    </div>

    ...sadly that's not only it. Pages now don't work either. Click on 'About' or any of the other links (minus 'The Underground') in the blue bar, it gives me a 404 error page, nothing to show, with the mod_rewrite rules in place (http://plainculture.com/about). Trying the regular method, /?pagename=about, gives me an (almost) blank page.

    Showing posts works though (click on any post in 'Movies', 'Writings', ...). But it's pages and getting the recent posts on the front page to work, they're not working.

    Any idea if this is a database problem or something my host just did? Help would be appreciated.

  2. jonthejester
    Member
    Posted 9 years ago #

    Nevermind...I had to run a custom query, away from the standard front page stuff wordpress does (like this: $temp_query = $wp_query ... $wp_query = $temp_query), and I was able to find my stuff on those pages in the database and recreated them. Problem's solved.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags