WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Twitter Bootstrap CSS
[resolved] The Bootstrap Collapse Function not working after latest plugin update (4 posts)

  1. rocomu8
    Member
    Posted 1 year ago #

    The Collapse function included in Bootstrap was working perfectly on my site until I did the latest upgrade to the plugin. Here is my code, I have no idea why it stopped working:

    BUTTON
    <button type="button" class="btn btn-red btn-apply" data-toggle="collapse" data-target="#form<?php the_ID(); ?>">Apply Now</button>

    CONTENT

    <div id="form<?php the_ID(); ?>" class="collapse job-apply">
    <?php the_content(); ?>
    </div>

    Please let me know if you have any suggestions as to how to fix this.

    Here is the website's link: http://www.chusmart.com/jobs/
    The button is the Apply Now red button for each job.

    Thank you

    http://wordpress.org/extend/plugins/wordpress-bootstrap-css/

  2. Paul G.
    Member
    Plugin Author

    Posted 1 year ago #

    Yep,

    Your site is on WordPress < 3.5 so it doesn't support the CDNJS feature where you replace your JQuery with the CDNJS. My guess is that you were using the option before when it was using the Google CDN. I changed this a while back to use CDNJS.

    The best solution going forward is to upgrade your WordPress to 3.5 or deselect the option to use JQuery CDN.

    I'll consider a work-around for the next release for people who want this option, but have WordPress < 3.5

    I hope that helps.
    Paul.

  3. Suresh Kumar
    Member
    Posted 1 year ago #

    @rocomu8
    You can try this bootstrap collapse plugin
    http://wordpress.org/plugins/bootstrap-collapse/

    Its using the jquery lib provided on wp

  4. Paul G.
    Member
    Plugin Author

    Posted 1 year ago #

    Just to be clear, this plugin also uses the JQuery from WordPress.

    The problem here was relating to when you use the option we provided to replace your JQuery with a CDN-hosted version, and you're on an out-dated version of WordPress.

    Thanks,
    Paul.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic