WordPress.org

Ready to get started?Download WordPress

Forums

the blog don't send any mail (7 posts)

  1. FernandoAlo
    Member
    Posted 4 years ago #

    Hi, sorry for my english, y don't speak english correctly.

    The problem: When someone try to register or put a comment, the blog don't send any mail to me and not send any mail to visitor or bloger. Initialy, i used the internal php mail, but only send mail when the domain are not public, when are gmail, hotmail, yahoo, no mail sent. If the mail of visitor are, of the same domain of the blog (ayudaurbana.org) the mail is sent to my and to visitor. I install the WP-smtp-mail to try fix the problem, but these give me an error "Failed to connect to server: Connection timed out (110)" when the data are the same of the configuration of outlook express.

    The question is: what are the requirements at hosting layer, to make smtp or php mail work correctly?

    I have installed the "PHP mail" module.

    Very sorry again for my english.

  2. Shane G
    Member
    Posted 4 years ago #

    Hi,

    Either you need to modify the wp-mail.php file and apply your domain email address and password in that file or install any of these plugins and configure it:

    http://wordpress.org/extend/plugins/wp-email/
    http://wordpress.org/extend/plugins/email-users/
    http://wordpress.org/extend/plugins/wp-mail-smtp/

    Thanks,

    Shane G.

  3. FernandoAlo
    Member
    Posted 4 years ago #

    Hi, thank you. I install the three plugins, but does't work anyone, even the mail test.

    I believe that is a problem of hosting, but i don't know who service don't work.

    Any sugestions?

  4. janosd
    Member
    Posted 4 years ago #

    I think the problem is with your host.

  5. FernandoAlo
    Member
    Posted 4 years ago #

    Thank you, i talked to hosting service and recognize the problem. Thank you everyone.

  6. bananajota
    Member
    Posted 4 years ago #

    hi janosd, i've installed http://wordpress.org/extend/plugins/wp-mail-smtp/ and setting up with the correct data, so the test email works fine and i get it on my inbox. But, always has a but, the new users never get the registration password. I receveid the email notify me about new user, so the problem is: WordPress don't send mail with password. Just that. Any clue?
    Regards.

  7. bananajota
    Member
    Posted 4 years ago #

    i fix it using an email on general options with my blog domain.
    Not hotmail or another free mail, just user@mydomain.com

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.