WordPress.org

Ready to get started?Download WordPress

Forums

Seamless Donations
[resolved] Thank you page missing (5 posts)

  1. dafilms
    Member
    Posted 1 year ago #

    Maybe I missed a step, but when the donation is completed at Paypal and the user click on the return to site button, it does not got to the thank you page, rather it goes back to the donations page. Can you help me figure out how to get the thank you page working.

    thanks for your help

    Dafilms-

    http://wordpress.org/extend/plugins/seamless-donations/

  2. Designgeneers
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi!

    It should display the text you specify. In your Dashboard, go to Seamless Donations and then Thank You Page - set the text you want there for the thank you page.

    Try a test donation again - and this time make note of the URL for the "Return to ...." link on PayPal. It should look something like this

    http://www.yourdomainname.com/donate-online/?thanks=1

    Let me know if it doesn't

    Cheers...

    ...Allen

  3. vytc0822
    Member
    Posted 1 year ago #

    Hi,

    I have this same problem. I just did test donations, but they all take me back to the donation page. The return url did not look like what you said it shoudl look like. It was super long and had a lot of stuff which i do not want to paste here. Is there maybe a setting I am missing? I mean I did go into the settings-->Thank You page and changed and updated it just to be sure there was something newly saved, but no go...any thoughts? This is a great plug in and I'd really like to get it working ---
    thanks!
    Veronica

  4. vytc0822
    Member
    Posted 1 year ago #

    I wanted to update just in case anyone else made the same mistake I did. The reason it was not working for me was that this needs to be set in your Website Payment Preferences in Paypal (including the settings in your Merchane Sandbox account if you are testing)

  5. allendav
    Member
    Plugin Author

    Posted 4 months ago #

    I found another way this could happen - and it is fixed in version 2.6.0

    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic