WordPress.org

Ready to get started?Download WordPress

Forums

Booking Calendar
[resolved] 'Thank you' message not showing (9 posts)

  1. lewelsch
    Member
    Posted 1 year ago #

    I updated booking calendars to the latest version 4.1.1 and since then the 'Show "thank you" message after booking is done' doens't show up anymore.
    if a new reservation is posted, the user never now if his message was successfully posted or not.
    any idea what this could be? it was working fine with the version before...
    thank you!

    http://wordpress.org/extend/plugins/booking/

  2. wpdevelop
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,
    Please open the General Booking Settings page, and recheck that you are correctly set the "Thank you" message, and the time for showing of that message, then click at the "Save settings" button.
    If you are see that these settings correctly set, please still click at the "Save" settings button.
    If you are still will have this issue, please send the link to the page with your booking form, where this issue is exist.

  3. lewelsch
    Member
    Posted 1 year ago #

    Hello,
    I rechecked the Thank you message - changed the text a little bit - and did a test.
    It is still not working.
    the site is:
    http://www.ferien-weggis.ch

    it is a multilingual site.
    thank you for your support!

  4. wpdevelop
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,
    The issue is belong to the permissions to the files. Your reservations are not created at all from the client side, thats why the "thank you" messages is not show.
    During creations of the new reservation, the booking system is send the ajax request to this file: http://www.ferien-weggis.ch/wp-content/plugins/booking/wpdev-booking.php
    But your server is not allow access to this file, its just show the "Not Found" error. The correct message which have to show, when you open that file directly is "You do not have permission to direct access to this file !!!". Please contact your administrator or support of the hosting company to set the appropriate security settings or permissions to that file/(plugin folder).
    Please read more here.

  5. lewelsch
    Member
    Posted 1 year ago #

    Hi
    my blog is physically not directly under http://www.ferien-weggis.ch, but under
    http://www.ferien-weggis.ch/directory_I_dont_name_here/wp-content/plugins/booking/wpdev-booking.php

    if I direct access to the file with the additional directory, I get the no permission message.

    is it related to the fact that the wordpress URL isnt the same as the site address?

    best regards

  6. wpdevelop
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,
    the booking system have to know, where is located the "wpdev-booking.php", otherwise its can not send the requests about the new resrvations, etc. Probably you are need to set some correct values at the WordPress Settings page for the "WordPress Address (URL)" and "Site Address (URL)" (please check the difference in those links at the link bellow those options), to be sure that the booking calendar can access to the "wpdev-booking.php" file then. Please contact your server administrator or support of hosting company about help in such configuration.

  7. lewelsch
    Member
    Posted 1 year ago #

    Dear support,

    I did some further investigations.

    If I setup a blog -> install booking calendar -> all is working fine.
    As soon as I use give my WordPress its own directory according the official WordPress guidelines , the error described in this topic occurs.
    I added for your convenience the link to get WordPress its own directory here:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    I would appreciate if you could have a look at this as this is a common scenario. Hope you can either update your plugin or provide me with a workaround...

    thank you and best regards

  8. wpdevelop
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,
    Please try to make this fix.
    Please open this file: ../booking/lib/wpdev-booking-class.php
    find this code:

    var wpdev_bk_plugin_url     = '<?php echo get_home_url(null, '/wp-content/plugins/'.WPDEV_BK_PLUGIN_DIRNAME ); ?>';

    and replace it to this code:
    var wpdev_bk_plugin_url = '<?php echo get_site_url(null, '/wp-content/plugins/'.WPDEV_BK_PLUGIN_DIRNAME ); ?>';

    This fix will be exist in the next update.

  9. lewelsch
    Member
    Posted 1 year ago #

    Hi

    Thank you for this fix! It helped and my site is working again as expected:-)
    Thanks,
    Bye

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.