WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Text/Visual Editor Defaults to larger than screen size vertically (13 posts)

  1. evilcrusher
    Member
    Posted 1 year ago #

    As of upgrading to 3.5 I've noticed that the Visual/Text Editor on the back end defaults to a length that is much longer vertically, than my screen and requires reducing it sometimes as many 4 scrolls of the screen to return it back to normal. To try to counter around this, I started using the full screen editor, and upon the first minutes of writing it worked fine. When the text got to be longer than the screen could display, it forced the browser to go back to the all posts page. Upon return back to writing a post, it began happening on the full screen editor as well.

    Is anybody else having this problem? What can I do to try to fix this?

  2. momentofzen
    Member
    Posted 1 year ago #

    Yes, I'm having this same problem!

    Can someone please advise how to fix this?

    Thanks.

  3. I think that with the new release they changed the behavior of the visual text editor and allowed you to keep your last setting. Meaning that if increased the window, in the past, you would have to do this every time, but not the preferences are kept.

    So what I would try is resize the window, by dragging the bottom right hand corner up and see if the settings are kept.

  4. momentofzen
    Member
    Posted 1 year ago #

    Thanks for the reply. Unfortunately, I've tried that but still no luck. I've tried reducing the window by dragging it to a much smaller size, and then press update, but it reverts to the excessively long height. I've also tried reducing the height by dragging and then just clicking to view another post but it again reverts to the super long height.

    Any other ideas?

  5. I would try deactivating all your plugins. Perhaps one of them is causing havoc with this. It seems very strange. You could also try another browser.

    I'm not very sure. :(

  6. momentofzen
    Member
    Posted 1 year ago #

    Thanks. Yes, I've tried other browsers but still encounter the same problem. I'll try de-activating plugins and see if they are causing the issue.

  7. GlendaG
    Member
    Posted 1 year ago #

    Exactly the same thing on my site, it's so annoying scrolling all the way up the page to find my editing tools. Only happened with the upgrade. Is this a bug for this version?

  8. evilcrusher
    Member
    Posted 1 year ago #

    I tried the plugins and the update. Neither worked. Tried in IE cause Im using Chrome. Didn't fix it.

  9. funstix
    Member
    Posted 1 year ago #

    Same problem here. Have tried every which to fix it with no result. I'm hopeful the next update will fix the problem.

  10. ldsphilosopher
    Member
    Posted 1 year ago #

    This is a BIG problem for me too, and I'm desperate for a fix!!! Will someone please help us all?

  11. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    If you need help, you need to start your own thread, and start working on all of the troubleshooting steps in this thread:

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

  12. funstix
    Member
    Posted 1 year ago #

    Hi follow this thread and look for the post by Kymar with the reference to line 74 & 75.

    i followed this and it worked fine.

    http://wordpress.org/support/topic/edit-box-has-gotten-enormously-long-and-setting-for-it-is-gone?

  13. evilcrusher
    Member
    Posted 1 year ago #

    Thank you very much Funstix. That was the answer is needed and has solved my problem.

    kymar
    Member
    Posted 1 month ago #

    OK - mrmonster - not sure why this happens, maybe if you "just once" resize your editing box to very large, you get stuck in a loop

    but this works for now at least as a hack:

    in the includes/class-wp-editor.php file you'll find

    Line 74: elseif ( $set['editor_height'] > 5000 )
    Line 75: $set['editor_height'] = 5000;
    if you change the last 5000 on line 75 to a smaller number - say 300 or whatever you prefer - then save the file, the ginormous box will re-size to that height.

    May later look at more elaborate fixes or commenting out more code, unless someone who KNOWS comes along with a real fix.

Topic Closed

This topic has been closed to new replies.

About this Topic