WordPress.org

Ready to get started?Download WordPress

Forums

Text Widget - Limits? (9 posts)

  1. tin68
    Member
    Posted 5 years ago #

    I am using a theme with widgets and there I am using a "text" widget for the sidebar.

    My short question: Is there any limit of number of lines or characters of implemented text and HTML code?

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Near as I can see, no, there's no size limit.

    Your browser might limit the amount of text it'll send over in a POST though.

  3. freejackcity
    Member
    Posted 4 years ago #

    I'm having an issue with line limits, I'm using text widgets in my footer and it is only allowing me about 9 lines:

    http://freeindependentsun.com

    i want the widgets to be as long as my text on the right side of my footer. anyone have any suggestions?

  4. ldexterldesign
    Member
    Posted 4 years ago #

    I'm using v2.7.1 and I suspect there is a character limit on text widgets. One of my text widgets keeps on disappearing and it's causing me hell. The character count is near 3000.

    I can see the content is in my DB through phpMyAdmin, but not displaying. Can anyone suggest an field option to amend: http://tweetphoto.com/5782551 ?

    I'm thinking more it might be a scripting issue, as if the data was too long the practical solution would be to throw a validation error in WP and not let the data to pass.

    Is someone able to quickly try this out with a version of WP?

    Thanks,

  5. ldexterldesign
    Member
    Posted 4 years ago #

    I'm right. It does have a limit of some sort. Beware.

    I just tested my theory out by splitting the 3000 character into 2 text widgets and my widget hasn't disappeared this time. Logic tells me the limit is somewhere between 1125 and 3000 chars.

    Hope this helps someone down the line.

    Cheers,

  6. alchymyth
    The Sweeper & Moderator
    Posted 4 years ago #

    @freejackcity:
    your case is a css issue: in the style.css of your theme:

    #footer-sidebar		{ width: 690px; float: left; overflow: hidden; margin: 10px 10px 0; }
    #footer-sidebar .widgetcontainer	{ float: left; margin: 0 0 15px 0; max-width: 250px; max-height: 120px; }

    you have a setting with 'max-height: 120px;' and an 'overflow: hidden;'

    delete both bits and you should see the full lists.

  7. freejackcity
    Member
    Posted 4 years ago #

    @alchymyth:

    I'm not finding those lines in my style.css code, I'm using the Arras Theme (haven't had a reply on their forums):

    /*
    Theme Name: Arras Theme
    Theme URI: http://www.arrastheme.com/
    Description: Magazine-styled theme with tons of features. Ready for alternate styles. Includes featured posts slideshow, different post layouts, multi-tabbed sidebar, custom single meta fields for reviews and many other customisable features.
    Author: Melvin Lee
    Author URI: http://www.zy.sg/
    Version: 1.3.5
    Tags: blue,brown,white,light,two-columns,three-columns,left-sidebar,right-sidebar,fixed-width,theme-options,threaded-comments,sticky-post,microformats
    .
    Arras.Theme, like WordPress, is released under the GNU General Public License, version 2 (GPL).
    
    For more information about the GPL, please visit:
    http://www.gnu.org/licenses/old-licenses/gpl-2.0.html
    
    If you require any support, please visit the theme website at
    http://www.arrastheme.com/.
    .
    */
    
    /* Trick the WordPress Theme Bot *Evil* */
    .aligncenter			{ display: block; margin: 0 auto; }
    .alignright				{ float: right; margin: 0 0 1em 1em; }
    .alignleft				{ float: left; margin: 0 1em 1em 0; }
    .floatleft				{ float: left; }
    .floatright				{ float: right; }
    img.aligncenter, img.alignright,
    img.alignleft			{ border: 3px solid #EEE; }
    
    .wp-caption { border: 1px solid #DDD; text-align: center; background: #F3F3F3; padding-top: 4px; margin: 10px }
    .wp-caption img { margin: 0; padding: 0; border: none }
    .wp-caption .wp-caption-text { font-size: 11px; line-height: 17px; padding: 0 4px 5px; margin: 0 }
    
    /* Default Stylesheet */
    @import url('css/default.css');
    
    /* User Override Stylesheet */
    @import url('css/user.css');

    Any Ideas?

  8. alchymyth
    The Sweeper & Moderator
    Posted 4 years ago #

    you are right - i was not looking close enough:

    the css file is actually:
    http://freeindependentsun.com/wp-content/themes/arras-theme/css/styles/default.css.
    the styles in question are nearly at the end of this file.
    if you look from the level of your theme directory, it is located in:
    /css/styles/default.css

    you may not be able to edit it from within the dashboard, so you need to use ftp, downlaod the file, make the changes and load it up again.

  9. freejackcity
    Member
    Posted 4 years ago #

    @alchymyth:

    Awesome, was able to edit the file with my cpanel file manager (sustainable websites). I tried just delete both bits but that didn't work so I changed the max height to 600, and now it works. For some reason the 'overflow:hidden" bit re-appeared after delete and save. What would be the setting to not hide overflow? either way, it's working now! Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic