WordPress.org

Ready to get started?Download WordPress

Forums

Text widget coding errors (2 posts)

  1. Jessica
    Member
    Posted 4 years ago #

    Help! I was trying to add the code for a "grab my button" in a text widget box and I got these errors:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home2/thejoyfu/public_html/wp-includes/widgets.php on line 686

    Warning: Invalid argument supplied for foreach() in /home2/thejoyfu/public_html/wp-includes/widgets.php on line 686

    Warning: Cannot modify header information - headers already sent by (output started at /home2/thejoyfu/public_html/wp-includes/widgets.php:686) in /home2/thejoyfu/public_html/wp-login.php on line 267

    Warning: Cannot mod

    Now I can't even use my WP control panel anymore. I use Cyberduck through BuleHost to manage my files, but I don't know how to get to the lines that are in error and how to fix them when I get there. I have found the file /home2/thejoyfu/public_html/wp-includes/widgets.php in Cyber duck, but then what?

    Where do I start?

  2. iridiax
    Member
    Posted 4 years ago #

    Using FTP, try replacing the widgets.php file with a fresh copy from the same version of WordPress.

    http://wordpress.org/download/release-archive/

Topic Closed

This topic has been closed to new replies.

About this Topic