WordPress.org

Ready to get started?Download WordPress

Forums

Text of posts and pages squished over to the right (9 posts)

  1. Thea
    Member
    Posted 2 years ago #

    I've just designed a new wider theme for my bellydance website (bellydanceoz.com) (to accommodate high def videos), but it simply won't display properly.

    It looks fine in Artisteer, but when I upload it, all the text in the central column, on both posts and pages, is indented - it's as if the left margin has been set halfway across the page.

    I don't think it's an Artisteer problem, because I've installed new, wider themes on my ballet and tribal sites without any trouble, using the same base template. Also I've tried redesigning it three times and the same thing happens every time.

    Does anyone have any idea where I could start looking for the source of the problem?

  2. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Start by sorting out the markup errors.

  3. Thea
    Member
    Posted 2 years ago #

    Thanks Esmi, I haven't seen that tool before. I will try uploading the new theme again and run it.

    However I must say, the tool does throw up a lot of results I don't understand - why would it pick on links created by WordPress, not by me?

  4. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    None of those results are false. Start at the top and work down - solving issues as you go - and you may find that some of the latter errors are automatically cleared.

  5. Thea
    Member
    Posted 2 years ago #

    Thanks Esmi, I appreciate your help. Unfortunately I don't understand the first thing about code, so most of these errors are Greek to me. Also, most of these errors are on links not created by me - the e-Junkie one is an affiliate link, for instance, copied and pasted direct from their site. And wouldn't the links be broken if they were incorrect?

  6. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Not necessarily but the markup problems could throw the layout completely off.

  7. Thea
    Member
    Posted 2 years ago #

    Question - if there is an ampersand (&) in the code in a sidebar widget, do I need to manually change it to &amp

  8. Thea
    Member
    Posted 2 years ago #

    Sorry, I'm completely bamboozled by the markup explanations, even though I've read the verbose stuff and read through all the linked explanations too.

    According to the markup, almost everything about this code is wrong:

    <a href='http://ameraspalace.com.au'><img src="http://bellydanceoz.com/wp-content/uploads/ameraspalace.png"border="0" height="572" width="186"</a>

    It's highlighting the opening quote mark before http, the bracket before img, the bracket before the final /a, the bracket after the final /a

    In another section, it picks up the "h" of "http" and in another error, the second slash in http://

    How can those be wrong?

    Is there anywhere this stuff is actually explained?

  9. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    I can't see anything wrong in your linked page;

    have you tried to clear the browser cache to get to see the latest changes - for instance by pressing 'CTRL F5' in windows browsers?

    the validation errors refer possibly to:

    <p><a href=http://bellydanceoz.com/about-2/contact/>Contact Us</a> | <a href=http://bellydanceoz.com/contact/privacy/>Privacy Statement</a>

    where you have ommitted to use quotatin marks aroung the link url; should read:

    <p><a href="http://bellydanceoz.com/about-2/contact/">Contact Us</a> | <a href="http://bellydanceoz.com/contact/privacy/">Privacy Statement</a>

    (there might be more similar errors...)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags