WordPress.org

Ready to get started?Download WordPress

Forums

WP Biographia
[resolved] Text links are vertically aligned due to pipe paragraphs (3 posts)

  1. peterdoerrie
    Member
    Posted 1 year ago #

    Hi,

    thank you for the nice plugin. I successfully solved some CSS issues thanks to your tips in this forum, but am a bit at a loss now. If I select text links in the Author profile, they will be displayed in a vertical order, intersected with the pipe symbol. Inspect tells me that the culprit is a paragraph incapsulating the pipes, but I am at a loss how to change that.

    Example: http://www.afrikaecho.de/2013/01/zentralafrikanische-republik-erste-schritte-friedensabkommen/
    Browser: Chrome (latest version) / Firefox (unknown version)
    Worpress: 3.5
    Plugin: latest version

    Thanks,

    Peter

    http://wordpress.org/extend/plugins/wp-biographia/

  2. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    I've just taken a look at the code of your site, specifically your example post, and you're absolutely right. Something is interfering with the HTML code for the Biography Box that WP Biographia produces. The pipe symbol that separates the contact links should not be enclosed in paragraph tags; this isn't what the plugin emits, so it's not an unfair assumption to assume that either another plugin or your theme is either installing a the_content filter or is running wpautop on the contents of your post, plus the Biography Box, after WP Biographia has finished running.

    There's a couple of things you can try. Either lower the the_content filter priority via the Content Filter Priority setting or ensure that wpautop (automatic paragraph formatting) runs before the Biography Box is produced via the Synchronise Automatic Paragraph Formatting For Content setting. You'll find both of these via Dashboard -> Settings -> WP Biographia -> Admin tab.

    Give this a try and let me know how you get on ... alternatively, let me know if this makes no sense whatsoever!

    -Gary

  3. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Haven't heard back in over 2 weeks on this so I'm assuming you've sorted the problem and I'm marking this thread as resolved; feel free to reopen it if that's not the case.

    -Gary

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic