WordPress.org

Ready to get started?Download WordPress

Forums

Text jumps each time I type in my blog (18 posts)

  1. erwin33
    Member
    Posted 4 years ago #

    I don't no what this is. But everytime I type a posting on my blog. The text jumps but the cursor stay on place. It's very anoying. Is this a bug or is there a fix for it? I hope someone can help me out. Thanks.
    Specs: WordPress 2.8.1., IE 8.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems.

    - renaming the plugins folder via FTP

    - reading http://wordpress.org/support/topic/279132

  3. erwin33
    Member
    Posted 4 years ago #

    All things tried but nothing helps.

  4. erwin33
    Member
    Posted 4 years ago #

    Maybe it's the automaticly safe draft option. So everytime I type and the text jumps up to the beginning the safe draft time changed. How can I resolve this?

  5. Samuel B
    moderator
    Posted 4 years ago #

  6. erwin33
    Member
    Posted 4 years ago #

    Ok, thanks I'll try that plugin.

  7. Cavalary
    Member
    Posted 4 years ago #

    This text jumping on autosave issue is what happens in IE8. Wrote about it just a couple of days after it launched and hoped it'd at least be solved by WP 2.8 if nothing was done before, but apparently nobody cared. Actually, 2.8 made it worse than 2.7, the text tending to jump pretty much constantly, more so the longer the post was.
    And I don't think that disabling autosave (or using a different browser) are solutions. Heck, the autosave is very likely the last added WP feature that I actually find useful for what I use it for.

  8. Samuel B
    moderator
    Posted 4 years ago #

    the autosave is very likely the last added WP feature that I actually find useful for what I use it for.

    man I hate that feature - every autosave, it increments the post id
    you can jump from post id 39 to post id 120 in one post - dumb!

  9. erwin33
    Member
    Posted 4 years ago #

    Yes, I notice that it is a IE8 problem. I'll try to make a post in IE7 and it works good. But when disabling autosave with that plugin works for the time being? Or not?

  10. Cavalary
    Member
    Posted 4 years ago #

    Ah yes, I hate that post number problem, but that's not because of autosave, but because of post revisions. Before implementing post revisions (in 2.6 I believe?) it didn't do that. Still, saw that you can reduce that problem by adding
    define('WP_POST_REVISIONS',false);
    to wp-config.php. With that it just adds one post revision if it autosaves when you edit it after posting. Would be nicer if it wouldn't do that either but uh well.

  11. erwin33
    Member
    Posted 4 years ago #

    Ok, I have added this line on my config.php Hope this helps for the time being before there is an upgrade to resolve the whole problem in 2.8.1. I'm now on a PC with IE7 so I can't check it if it's works fine now, so I hope the problem is resolved.

  12. Cavalary
    Member
    Posted 4 years ago #

    Um, adding that line had nothing to do with the text jumping issue, it was about what samboll said about the post number being incremented every time it saved. (Which means that if you actually use post revisions, you really should remove it right away. If you don't use them you can leave it there well enough and get rid of an annoyance :))

    Back to your (and my...) issue, until somebody'll actually write a fix for it (if one already exists, do let me know!), running your site under compatibility mode in IE8 should help... I think.

  13. erwin33
    Member
    Posted 4 years ago #

    And how can I set my site in compatibility mode?

  14. Cavalary
    Member
    Posted 4 years ago #

    There are 3 buttons to the right of the address bar: compatibility view, refresh and stop. While on your site, click the first one. By default, it will make the entire domain the site's on run under compatibility mode and the setting will be saved (you'll see that button light up whenever you go to the site).

  15. erwin33
    Member
    Posted 4 years ago #

    Ok thanks.

  16. jollymoon
    Member
    Posted 4 years ago #

    I really, really hate the jumping editor window!

    I have noticed that even if you disable the AUTOSAVE the window will jump back to almost the top of the editing window if you move the cursor out of the text editing window...

    As long as your cursor stays in the editor it won't jump, but if you move to another function, like select a category or edit the tags, the stupid cursor jumps back to almost (not quite ??) the top of the editor window. Increasing the size of the edit window just increases the size of the "jump"...

    Why can't the edit window just stay where you left it if you move your mouse? Is there an alternate "editor" plugin?

    Very, very annoying.

  17. jollymoon
    Member
    Posted 4 years ago #

  18. slamradio
    Member
    Posted 4 years ago #

    the IE8 compatability view button fixed the issue for me, thank you! ;)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags