WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Text is pale grey on first visit to Home page (7 posts)

  1. RobClack
    Member
    Posted 1 year ago #

    The first time I visit my Home page, the text is pale grey, which is really hard to read on a white background. On subsequent visits, the text is the correct dark grey. I see nothing in the HTML to control the text colour, so I assume that's in a CSS file somewhere.

    Also only on the first visit, there's an 'Uncategorized' link at the bottom of the page. Clicking this takes me to a page with a breadcrumb line Home >Archive for Uncategorized, which is formatted like a blog with Recent Posts, Recent Comments, etc, on the right-hand sidebar.

    The website is hosted on someone else's server and I only have editorial control of the content, not admin privileges that would allow me to access the theme, which is Shell.

    Any ideas as to what's causing this behaviour and what I can do to fix it?

  2. s_ha_dum
    Member
    Posted 1 year ago #

    ... what I can do to fix it?

    Without access, probably nothing, but what is your URL? Have you tried a different browser or another computer?

  3. RobClack
    Member
    Posted 1 year ago #

    I've tried it in Firefox, Chrome, Opera and IE8, all are the same. The guy who has to sign the site off as ready to go live can see it, and he sees the same problem.

    If I knew where in the theme the problem might be, I could point the web specialist in the right direction to see if she could fix it.

  4. s_ha_dum
    Member
    Posted 1 year ago #

    It is CSS or Javascript, and is probably in your theme, but it is hard to say exactly what or where without more information. I know that is very vague, which is why I asked for an URL earlier. Do you have an URL? (Sounds like you might not.)

    I would lean towards Javascript, slightly. Disable Javascript and see what happens. That might narrow it down.

  5. RobClack
    Member
    Posted 1 year ago #

    I log in using an IP address, but I think I'm probably not authorised to tell you what it is! I don't work directly for the organisation on whose server the website is hosted. Once the site goes live, which should happen any day now, then I could tell you the URL, but it doesn't work yet.
    I'll email your last response to the web person and see what she says.
    Thanks
    Rob

  6. s_ha_dum
    Member
    Posted 1 year ago #

    I log in using an IP address, but I think I'm probably not authorised to tell you what it is!

    I understand. That makes it very hard to help though.

  7. RobClack
    Member
    Posted 1 year ago #

    Problem solved. Ages ago, to get rid of the default Home Page which the theme came with, which I seemed unable to edit or delete, I created a custom menu, which I hooked up with the pages I did want to display.

    Somehow, I ended up with two copies of my real Home Page, one of which opened in Edit, the other when you first viewed the page. No idea how that came about, nor why the latter had pale grey text.

    When I removed the Home Page from the menu, and then re-added it, I noticed a second Home Page lurking, identified by Home:Home.

    Oh and I changed Settings -> Reading to display a Static page, for which I selected Home.

    Doesn't tell me <i>why</i> it happened, but it got rid of it, which is the main thing for me.

    Thanks for trying to help.

Topic Closed

This topic has been closed to new replies.

About this Topic