WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] text editor not working for links (5 posts)

  1. HCSdesigns
    Member
    Posted 5 years ago #

    I have been attempting to put liks in my home page to a post the direct links will not work. They look good and then when I click update they change. http://test.letthebiblespeak.com/

    I have used the visual tool and I have tried inserting them in html format.

    Any help would be appreciated.

  2. wp-rory
    Member
    Posted 5 years ago #

    Hi,

    I'm not sure I understand exactly the problem you are having, but I had a quick look at your site and the first link, labelled 'Come After Me', has the following link address:

    http://test.letthebiblespeak.com/"http://test.letthebiblespeak.com/afterme"

    It seems that somehow that address has become garbled up. You might try replacing that address with the following address:

    http://test.letthebiblespeak.com/afterme

    When I typed that address in I got to another page, not to an error 404 so I suspect it may be correct :)

    --

    If that fixes the problem, then read no further. Just as a postscript, though, if you are writing your post in HTML, a good way to insert a link is as follows:

    <a href="http://yoursitehere.com">Click Here to go to my Site!</a>

    Naturally, you would replace the 'yoursitehere.com' with the real address of the page or site you want to link to, and the 'Click Here to go to my site!' with whatever text you want to be visible on the page.

    All the best,

    Rory. :)

  3. HCSdesigns
    Member
    Posted 5 years ago #

    Thank you for the look. It is so strange. I have worked with wordpress on 2 sites today and adding hyper links will not work.

    I added this hyerlink: Come After Me

    after I click update and refresh the page on my website it looks like this:
    http://test.letthebiblespeak.com/%22http://test.letthebiblespeak.com/afterme/%22

    for some reason it makes 2 copies of the link along with spaces and these [/%]

    Do I need to re install workpress? Someone suggested for problems with the text editor to install the pugin - fckeditor.

    I did that and still have the same problem.

  4. wp-rory
    Member
    Posted 5 years ago #

    Hi again,

    If you are happy with HTML, then only use the HTML editor and disable the Visual editor in your profile (click your name at the top-right of the Dashboard). Then try a clean 'a href=' style link and save it and check the page. It should work, but if not you could try a re-install or install a better WYSIWYG editor as you suggest.

    All the best,

    Rory. :)

  5. HCSdesigns
    Member
    Posted 5 years ago #

    thank you wp-rory for your attempt to help.
    I found out my problem was not with the editor at all. In another post I found the answer to my problem:
    http://wordpress.org/support/topic/257446?replies=4#post-1031428

    It was the "magic quote" setting on my server.

    I am setting up this site and use a combo of html and the visual editor. but I eventually want my client to be able to use the visual editor himself.

    Now that I have wordpress working for me I will pass along my praises of it :) Have a great day!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.