WordPress.org

Ready to get started?Download WordPress

Forums

Text Editor and Java Script Problem (3 posts)

  1. PhillS
    Member
    Posted 8 months ago #

    I have been using WP for about two years. During that time I have included without problems javascript with posts that provide a sign up box for subscriptions. The js is created by the GetResponse web form manager and I just paste the script into the text editor when I have written my blog piece in the visual editor. This has worked without problem until this week.

    Since the most recent update to WP, this function varies between 'hit and miss' and 'doesn't work at all'.

    After pasting into the text editor, when I return to the visual editor I find that the formatting of my post is changed - dot point lists aren't consistent and some line breaks disappear. Or I find that the js hasn't worked at all - no sign up box appears.

    Any advice on what may have changed in the past week and what should do now?

  2. WPyogi
    Volunteer Moderator
    Posted 8 months ago #

    Switching editors is a known problem - it does strip code - it's been that way for a while, not sure why it's different for you know.

    JS can't be put in the editor that way - http://codex.wordpress.org/Using_Javascript

    You could try this plugin:

    http://wordpress.org/plugins/css-javascript-toolbox/

  3. kmessinger
    Volunteer Moderator
    Posted 8 months ago #

    After pasting into the text editor, when I return to the visual editor I find that the formatting of my post is changed

    The common consensus is to use one or the other. Save the js until last and don't switch back to the visual editor.

    You might want to contact GetResponse and ask if the current version is compatible with WordPress.

    You can also start a basic debug. Turn off all plugins, revert to the default theme and check GetResponse. If it works there, start restoring until you find the problem.

Reply

You must log in to post.

About this Topic