WordPress.org

Ready to get started?Download WordPress

Forums

Editor changes text layout (5 posts)

  1. therealkickers
    Member
    Posted 4 years ago #

    Hi folks!

    I´m quite new to WordPress and I´m German too, so post slowly, I might need a few moments to get what you are telling me (hopefully) :-)

    I´ve been using WP for about a week now and I have one thing wich drives me mad:
    For what I think it is nearly impossible to create a straight formatted text site containing the most simple html code you can imagine.
    All I want to do is write a text that contains a few headlines in a typical format, some colums of text in another format (smaller font of course, different color) and I need to have the same ammount of space between headlines and text colums every time.

    First I kept failing using the visual screen mode. I wanted white text and - surprise - I could hardly work in the visual mode any more. I turned back to black and then it all began. Whenever I added a space line or I changed the size of a headline (no matter if I used h-tags or just bigger font sizes) the editor wildly added stuff into my text. Line breaks, dozens of them. Here and there. It moved colums from where they belong to the bottom of the page. It added "-" whereever it thought they might fit. Deleting empty lines that the editor added caused other weird happenings to my documents. I add one line, the editor removes one. I add two lines, the editor adds 10 (!) lines. I remove nine lines, the editor adds "-" in front of some lines or resizes the complete font.

    I gave up and thought, hey, why not forget about that visual mode, just delete the whole stuff and type plain html from the beginning into the html screen mode of the editor?. I did so and first everything was fine. The layout was the way I wanted it.

    Yesterday I checked back to the page in my editor because I wanted to correct a spelling error. There it was again: The editor had completely reworked my very own manual written html code back to his own making ups which I recognized by hundreds of "span" tags it kept adding. I corrected my spelling error and saved - wham. Everything went crazy again. Wrong font sizes, "-", empty lines - all the stuff I thought I had avoided using the html mode.

    I did a restore to my latest saving step and there was my hmtl code again. Saved - all ok. today I check back, everything gone crazy again.

    Aaaargh! Please dear worpress editor - let *ME* decide what appears on my website in which layout. Why does this thing keep changing format tags, no matter if you use the visual or the html mode?

    Is this a bug or a feature? Worpress is great, but if I cannot set the layout 100% I need it, the editor is useless and makes WP unusable for me in general.

    Any idea if this is all my fault? Did I miss a checkbox "[X] do not change my layout"?

    Please help me...
    Thank you!

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    If you're going to use the HTML tab to create posts/pages (and it does sound like this would be the best option for you), stick to the HTML tab. Don't use the Visual Editor. If necessary, navigate to Admin/Users/Your Profile and tick the checkbox to disable the visual editor.

  3. therealkickers
    Member
    Posted 4 years ago #

    Thanks esmi.
    But as I said, the problem is, even in html mode the editor keeps changing my code all the time. While I was logged in I entered all my html code in there and saved in about 10-15 steps. When I was finished, both the code I typed into the editor and the webiste looked perfect.
    Yesterday in the editor html window everything was screwed up again, although I didn´t touch anything. I then restored the previous step, which made the weird code gets replaced by "my" correct one, but the same keeps happening obviously every time I log out and back in.

    When I open that page in the editor now, the code in the html window is screwed up again, yet the website still seems ok. If I click the save button in the editor these "automated" changes go live and my website is messed up again.

    I can´t seem to find a way that the editor keeps it´s hands off my code :-(

    I hope it´s understandable, my Engish ist not perfect, sorry.

    Thanks!

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    Your English is far better than my German. :-)

    Do you have any active plugins? Have you tried deactivating them all to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    I use the HTML tab all the time and I have never had the kind of problem that you describe - which makes me think that there's something else screwing up your markup. A plugin would be the most likely culprit.

  5. therealkickers
    Member
    Posted 4 years ago #

    Thanks esmi!

    I have an extern slideshow built on my homepage, but it is located on a different page that where these strange things happen. Do you think it still could mess up my code, even if it is located on a different page?

    In my eyes this problem is caused only by the editor, because first only the written code in the html editor window changes, but nothing will happen to my website, until I save the automated code in the editor window. So if I leave it all alone, nothing will happen to my site, if you can understand what I´m trying to explain...

    I´ll check what happens if I spare the slideshow.

    Greetings

Topic Closed

This topic has been closed to new replies.

About this Topic