WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials by WooThemes
Testimonials plugin takes over /testimonials page of site (8 posts)

  1. Justin
    Member
    Posted 1 year ago #

    I'm having an issue with the Testimonials plugin where it appears to have auto-created an archive-like page at /testimonials. However, I already have a /testimonials page created with content and a shortcode of [woothemes_testimonials limit="10"] to display the testimonials. This page doesn't even show up though - only the archive-like testimonials page.

    Here is the testimonials page:
    http://wehoststuff.com/dev/buildinthemountains.com/testimonials/

    It has the same content as the following page and should show up exactly like the following, but doesn't:
    http://wehoststuff.com/dev/buildinthemountains.com/accolades/

    I've also submitted a couple of support tickets to WooThemes, but haven't heard back from them yet.

    Thanks for any assistance!

    http://wordpress.org/extend/plugins/testimonials-by-woothemes/

  2. ellebillias
    Member
    Posted 1 year ago #

    same here :/ displaying archive instead of page

  3. Justin
    Member
    Posted 1 year ago #

    I actually heard back from WooThemes's support about this issue, and they stated that this is done by design. As the testimonials plugin creates a custom post type in WordPress, it automatically creates the archive page for the name of the custom post type (in this case, "testimonials"). The only way that they gave me to work around this is to do as I had done already and name the page something other than "testimonials".

    If anyone has any other work-around's available, please let me know!

  4. Sandie
    Member
    Posted 1 year ago #

    I reported this via WooThemes support back in January, and was advised that the developer's advice had been sought and "...he is very keen on the idea of adding this functionality into a future version". I don't know if that is/was the same developers listed here on the repository.

    I was advised of this workaround which you'll need to remember to re-do each time you update the plugin (helpful screenshot was from WooThemes as well):

    1. Open the file class-woothemes-testimonials.php (located at /plugins/testimonials-by-woothemes/classes/class-woothemes-testimonials.php)
    2. At approx. line 99 (it sometimes changes when the plugin is updated), you'll see http://cld.wthms.co/VmYU. Change the 'has_archive' value from 'testimonials' to 'false'.
    3. Deactivate and re-activate your plugin after making the changes.

    Hope this helps.

  5. ellebillias
    Member
    Posted 1 year ago #

    yep that works - but it's pretty annoying if they update you have to go change it again, not sure why you would want an auto generated "archive" page as standard instead - i mean most people are going to want "testimonials" as the page with the shortcode in it!

  6. Justin
    Member
    Posted 1 year ago #

    I agree - it is very annoying. There should be a way to enable/disable archive pages like this in wp-admin, at least in the theme options.

  7. Michael Cannon
    Member
    Posted 11 months ago #

    I'm tooting my own horn here.

    Please give Testimonials Widget a look to see if it'll do what you really want.

    The default archive page URL slug is configurable and the default is NOT "testimonials" which is people want for their own page name.

  8. Sandie
    Member
    Posted 11 months ago #

    Thanks, I'll take a look ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic