WordPress.org

Ready to get started?Download WordPress

Forums

BackWPup Free - WordPress Backup Plugin
Test Email - Swift Mailer: Failed to create cache directory (5 posts)

  1. muffintop
    Member
    Posted 11 months ago #

    Hi,

    I'm setting up a backup job and trying to send a test email. However it keeps coming up with the error;
    'Swift Mailer: Failed to create cache directory C:/Server/Apache2/htdocs/events/wp-content/uploads/backwpup-98372-temp/5196006f2a997 Error while sending e-mail!'

    Sounds like a permission issue but I've not had this problem on any other site. I've checked the permissions and they are the same as other sites.

    Any ideas?

    Thanks,

    http://wordpress.org/extend/plugins/backwpup/

  2. Caspar
    Member
    Plugin Author

    Posted 11 months ago #

    Hi muffintop,

    do you receive other email notifications from your site like when a comment is awaiting moderation?

  3. Luis
    Member
    Posted 9 months ago #

    Hi there,

    I'm also having a similar problem. When clicking the Test Email button I get the following:

    Warning: mkdir() [function.mkdir]: No such file or directory in /path/to/domain/root/wpadmin/wp-content/plugins/backwpup/sdk/SwiftMailer/classes/Swift/KeyCache/DiskKeyCache.php on line 277
    Swift Mailer: Failed to create cache directory /path/to/domain/root/wpadmin/wp-content/uploads/backwpup-4a048-temp/51d3b1db4f365Error while sending e-mail!

    I've verified the /path/to/domain/root/ portion is correct. I have received emails from my site when I created user accounts as well as sending credentials to a test user email address.

    When looking at the file structure, /path/to/domain/root/wpadmin/wp-content/uploads/backwpup-4a048-temp does not yet exist.

    Thanks for your help!

    -Luis

  4. Luis
    Member
    Posted 9 months ago #

    Sorry, I meant to mention I also tried chmoding wp-content to 775 and 777, went back to the backwpup dashboard, tried the test email again, and still got the message.

    Best,

    -Luis

  5. Luis
    Member
    Posted 9 months ago #

    Update: It seems the problem is only with the Test Email bit. I tried running the job manually and got the email with the backup.

    -Luis

Reply

You must log in to post.

About this Plugin

About this Topic