WordPress.org

Ready to get started?Download WordPress

Forums

NinjaFirewall (WP edition)
[resolved] Test Configuration Button Loops Back to First Run (5 posts)

  1. majamaki
    Member
    Posted 5 months ago #

    After installing the plugin and going through the configuration setup I get the Test Configuration button, but when clicking the button it returns to the First Run screen. Seems to loop through the setup process and is not completing. Also I rebooted my server to update the cache, but no luck.

    I'm expecting to see the Ninja Firewall menu and options, but nothing. It always goes back to the first run page.

    In the setup, it looks like everything is working and being done correctly. I've confirmed via FTP that the php.ini and .htaccess files are getting created and/or updated.

    Your server is running PHP as CGI-FCGI SAPI
    Looking for a PHP INI file inside [file path removed] : found php.ini
    Checking if PHP INI is writable : yes
    Looking for [file path removed] .htaccess file : found
    Checking if .htaccess is writable : yes
    Checking if WordPress root directory is writable : yes

    I'm hosting on MediaTemple's DV service which is using Plesk. I'm trying this on one of my sites first, I'd like to try using this plugin on all my sites, but need to ensure it installs correctly and works.

    Server info:
    Linux: Apache/2.2.22
    PHP 5.3.27

    Any idea on what is preventing it from completing the setup?

    Thanks for your time and input.

    https://wordpress.org/plugins/ninjafirewall/

  2. majamaki
    Member
    Posted 5 months ago #

    Nevermind, I was able to get it working by uninstalling and deleting the php.ini file, then reinstall and use .user.ini file instead.

  3. nintechnet
    Member
    Plugin Author

    Posted 5 months ago #

    .user.ini is often the best choice for a dedicated (or VPS) server running PHP 5.3+.
    Plesk may also let you use the var/www/vhosts/YOURDOMAIN.COM/etc/php.ini file, but that would require to manually edit it.

  4. majamaki
    Member
    Posted 5 months ago #

    Thanks for the reply.

    Got new question. I'm getting a HIGH level notice for a custom php file I have called into my site. It's doing a GET call and the notice is: Forbidden direct access to PHP script

    There is no Rule # for it. How can I have the plugin ignore this call?

  5. majamaki
    Member
    Posted 5 months ago #

    I think I found the solution. I unchecked the "Block direct access to any PHP file located in one of these directories" for "/wp-content/uploads/*"

Reply

You must log in to post.

About this Plugin

About this Topic