WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Test-Config not running or blank results (11 posts)

  1. adam
    Member
    Posted 1 year ago #

    I'm running Postie 1.4.23 on a multi-site install 3.4.2, and having trouble when running the test-config script.

    Strange thing is that this works on my development server in a multi-site install. Postie takes all of my email address info, saves the plugin settings, and everything seems fine. When I run test-config, it doesn't display anything for "Connect to Mail Host" and no errors in the browser.

    The server is Apache 2 on Ubuntu 12.04, and has PHP5-IMAP installed. The mail host is local, running on Debian. Postie works on development server, but won't on Production server. I'm wondering if this is a permissions issue, where might I look for some info?

    http://wordpress.org/extend/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Have you tried capturing the error log as described http://postieplugin.com/enabling-debug-output/

  3. Mike-in-AK
    Member
    Posted 1 year ago #

    Same issue as adam. Blank page. But an error is generated in the site log. This has been going on for quite some time.

    Currently running Apache 2.2, WordPress 3.5.0 on Mac OS X server 10.6.8.
    Last known version to display the test config and "run postie" page correctly was version 1.4.14.

    And with the newest version 1.4.31, every page in the Dashboard displays the Warning: the IMAP php extension is not installed. Postie can not use IMAP, IMAP-SSL or POP-SSL without this extension banner. I know the extension is not installed and I don't care.

  4. Mike-in-AK
    Member
    Posted 1 year ago #

    Debug.log

    [28-Jan-2013 01:16:28 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:28 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:31 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:31 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:31 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:31 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:31 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:31 UTC] Postie: Checking for mail manually
    [28-Jan-2013 01:16:31 UTC] Postie: Starting mail fetch
    [28-Jan-2013 01:16:31 UTC] Postie: Time: 2013-01-28 01:16:31 GMT
    [28-Jan-2013 01:16:31 UTC] Postie: wp_content_path: /Library/WebServer/Documents/fortymile/wp-content
    [28-Jan-2013 01:16:31 UTC] Postie: Connecting to mail.fortymile.com:110 (pop3))
    [28-Jan-2013 01:16:31 UTC] Postie: There are 0 messages to process
    [28-Jan-2013 01:16:31 UTC] Postie: memory at start of e-mail processing:31771784
    [28-Jan-2013 01:16:31 UTC] Postie: Error log: /Library/WebServer/Documents/fortymile/wp-content/debug.log
    [28-Jan-2013 01:16:31 UTC] Postie: memory at end of e-mail processing:31771680
    [28-Jan-2013 01:16:34 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:34 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:34 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:34 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:34 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:37 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:37 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:37 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:37 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:37 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Library/WebServer/Documents/fortymile/wp-includes/functions.php on line 2923
    [28-Jan-2013 01:16:37 UTC] Postie: Error log: /Library/WebServer/Documents/fortymile/wp-content/debug.log
    [28-Jan-2013 01:16:37 UTC] Postie: Postie is in /Library/WebServer/Documents/fortymile/wp-content/plugins/postie
    [28-Jan-2013 01:16:37 UTC] Postie: iconv: installed
    [28-Jan-2013 01:16:37 UTC] Postie: <b>Warning!</b> Postie requires that imap be enabled.
    [28-Jan-2013 01:16:37 UTC] Postie: mbstring: installed
    [28-Jan-2013 01:16:37 UTC] Postie: GMT: 2013-01-28 01:16:37
    [28-Jan-2013 01:16:37 UTC] Postie: Current: 2013-01-28 01:16:37
    [28-Jan-2013 01:16:37 UTC] Postie: Sucessful POP3 connection on port 110

    Postie works, but displays a blank test-config and blank "Run Postie" page.

  5. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    @Mike-in-AK
    Thanks for the log. FYI all the has_cap warnings are coming from some other plugin.
    I don't see any Postie errors.

    >every page in the Dashboard displays the Warning
    This warning should not be displayed if you are set to pop3. I'll take a look.

    >Postie works, but displays a blank test-config and blank "Run Postie" page.
    I don't have a Mac set up to test this right now, but suspect it is working somewhat differently than Windows or Linux. I'll see if I can get something set up to test.

  6. smmcats
    Member
    Posted 1 year ago #

    Warning: the IMAP php extension is not installed. Postie can not use IMAP, IMAP-SSL or POP-SSL without this extension.

    I get that same warning and I'm tired of seeing it. I host with godaddy on a linux server, I think. I use windows firefox to login. How do I remove the warning?

  7. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Upgrade to 1.4.32

  8. mommaroodle
    Member
    Posted 1 year ago #

    I actually found this in WordPress 3.5.1/wp-includes/capabilities.php - and I did a search in every single file for the has_cap function - I removed a theme that had it and I was still getting the error

    /**
    	 * Whether role has capability.
    	 *
    	 * The capabilities is passed through the 'role_has_cap' filter. The first
    	 * parameter for the hook is the list of capabilities the class has
    	 * assigned. The second parameter is the capability name to look for. The
    	 * third and final parameter for the hook is the role name.
    	 *
    	 * @since 2.0.0
    	 * @access public
    	 *
    	 * @param string $cap Capability name.
    	 * @return bool True, if user has capability. False, if doesn't have capability.
    	 */
    	function has_cap( $cap ) {
    		$capabilities = apply_filters( 'role_has_cap', $this->capabilities, $cap, $this->name );
    		if ( !empty( $capabilities[$cap] ) )
    			return $capabilities[$cap];
    		else
    			return false;
    	}
    
    }
  9. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    @mommaroodle
    The has_cap function and related are still valid. It is just that some theme or plugin is calling it with an old-style number instead of a role name. add_submenu_page() is another function that can cause this notice if it is called wrong.

    Postie will not generate these notices.

  10. mommaroodle
    Member
    Posted 1 year ago #

    I was just saying, I dont use Postie, and I can absolutely guarantee you that neither my theme or plugins even as much as contain the words has_cap except the pages mentioned above and I also get the error msg - so I dont think that in all cases it's due to themes or plugins :)

    thx for replying though ^_^

  11. mommaroodle
    Member
    Posted 1 year ago #

    it definitely is the capabilities.php page that generates the error message - it can be found at roundabout line 918 in wp-includes/capabilities.php

    function has_cap( $cap ) {
    		if ( is_numeric( $cap ) ) {
    			_deprecated_argument( __FUNCTION__, '2.0', __('Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead.') );
    			$cap = $this->translate_level_to_cap( $cap );
    		}

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic