WordPress.org

Ready to get started?Download WordPress

Forums

terrible mySQL support from PHP (10 posts)

  1. gcorwin
    Member
    Posted 7 years ago #

    After futzing around with this for two days - reading countless help files, blogs and forums - I have come to the conclusion that unless WordPress ports itself over to .NET (or at least away from PHP) they are going to go the way of the dinosaur.

    I have used both for years and and I am giving up. It is near to impossible to get mySQL 4 and PHP 5 to talk with each other.

  2. MichaelH
    Member
    Posted 7 years ago #

    Hasn't MySQL 4.0 gone to 'the dinosaur?'

  3. IcelandDream
    Member
    Posted 7 years ago #

    What are you trying to do? Talking to MySQL (any version) is what PHP does best.
    WTF is .NET? :)

  4. vkaryl
    Member
    Posted 7 years ago #

    It's a piece of MS/windows - ah - "programming"....

  5. whooami
    Member
    Posted 7 years ago #

    hahah, I will hold my breath waiting for _anything_ to go the way of the dinosaur simply because its NOT ASP/IIS/.net friendly.

    Can I pulease take that bet???????????

  6. Doodlebee
    Member
    Posted 7 years ago #

    It's a piece of MS/windows - ah - "programming"....

    LOL..I can think of a better word than "programming"....good for you, trying to be nice ;)

  7. Trent Adams
    Member
    Posted 7 years ago #

    Sorry to go off Topic, but happy 1 year anniversary doodlebee on being an official WordPress forum user! Just noticed that and thought I would say congrats!

    Trent

  8. Doodlebee
    Member
    Posted 7 years ago #

    Wow - thanks Trent - I didn't even notice that!

  9. gcorwin
    Member
    Posted 7 years ago #

    I followed these instructions verbatim, and it still won't work. I even tried both isapi and the executable in IIS.

    http://www.php.net/manual/en/ref.mysql.php

    MySQL is no longer enabled by default, so the php_mysql.dll DLL must be enabled inside of php.ini. Also, PHP needs access to the MySQL client library. A file named libmysql.dll is included in the Windows PHP distribution and in order for PHP to talk to MySQL this file needs to be available to the Windows systems PATH.

    Don't get me wrong - I love WordPress, and mySQL, it's PHP that isn't playing nice. I've never had this much trouble setting anything up - even CFMX!

  10. Doodlebee
    Member
    Posted 7 years ago #

    PHP "isn't playing nice" because it's just not set up to do what you want.

    Like the error says - you need to have the php_mysql.dll enabled in the php.ini file (just a matter of uncommenting the extension line), and then you have to set MySQL to allow PHP to have access to it by making sure the path is correct.

    Just because something is *different* to you doesn't mean it's *bad*.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.