WordPress.org

Ready to get started?Download WordPress

Forums

WP Glossary
[resolved] Term Link - 'No Link' Option Doesn't Seem to Work (7 posts)

  1. bpence
    Member
    Posted 1 year ago #

    Under WP Glossary Options:

    Term link set to 'No Link' still creates links to each glossary item post. I don't want this to happen. Anyone else having issues with this?

    http://wordpress.org/extend/plugins/wp-glossary/

  2. TCBarrett
    Member
    Plugin Author

    Posted 1 year ago #

    Hi bpence

    There is an 'a' tag, but no 'href' link attribute. A bit like this:

    <span class="wp-glossary"><a class="glossary-term" title="" >camembert</a></span>

    Is this what you are getting? If not, could you post your option settings and a link to the page that isn't working?

  3. bpence
    Member
    Posted 1 year ago #

    Hi TCBarrett,

    Unfortunately with the Term Link set to 'No Link' I'm still getting the 'href' link attribute as an output. My current options are:

    Tooltip: Off
    Archive: Alphabetical
    Tooltio(qTip): Off
    Term Link: No Link
    Term usage: On

    A link to the glossary is here:

    http://fish.bpence.com/resources/

    (click on the 'Glossary of Insurance Terms' accordion to see the alpha list).

  4. TCBarrett
    Member
    Plugin Author

    Posted 1 year ago #

    That setting applies only to single term shortcode, it hasn't been implemented in the atoz or term_list shortcodes.

    Will add it to my to-do.

  5. bpence
    Member
    Posted 1 year ago #

    Ok thanks for letting me know. I just removed the href link attribute from line #44 of the wpg-shortcode-glossary-atoz.class.php file. That will work for now.

  6. TCBarrett
    Member
    Plugin Author

    Posted 12 months ago #

    General options can be over-written in the shortcode attributes from version 3.0

  7. bpence
    Member
    Posted 11 months ago #

    Yep that did it! Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags