WordPress.org

Ready to get started?Download WordPress

Forums

Templates is missing (22 posts)

  1. Ypanesa
    Member
    Posted 3 months ago #

    Since I startet my new website with customizr, I only get the error message, that the theme needs a stylesheet and a template. I downloaded the theme the normal way from the backend and directly from your website. I did that several times. This is the error message on the themes page. Even my hoster played arround and could not resolve the problem. Would you please help?

    Beschädigte Themes
    Die folgenden Themes sind installiert, aber nicht vollständig. Themes müssen ein Stylesheet und ein Template haben.
    Name Beschreibung
    Customizr Child Das Übergeordnete Theme fehlt. Bitte installiere das übergeordnete Theme "Customizr", da du Child-Themes sonst nicht nutzen kannst.

  2. WPyogi
    Volunteer Moderator
    Posted 3 months ago #

    That looks like you are using a child theme for Customizr? In that case, do you have the parent Customizr theme installed?

  3. Ypanesa
    Member
    Posted 3 months ago #

    I just copied the child theme in the folder, that's why it shows up. I could delete it. I restartet several times without a child theme. I install the customizr theme and get the error message. Of course I installed the parent theme. But you can not activate it, if there is something missing. Same for the child theme of course.

  4. WPyogi
    Volunteer Moderator
    Posted 3 months ago #

    Where is the child theme installed? In which folder? What is the code in the child theme style.css file? And please post a link to your site.

  5. Ypanesa
    Member
    Posted 3 months ago #

    It is in the folder "themes". There are 3 definitions in the css concerning titles. Let me restart once again. I delete the customizr theme, and the child theme and download it again, without child.

    Everything worked so fine on my local computer. Then I uploaded the site in a subfolder. Later on I wanted to copy it one level higher and the problems started. It seems that customizr don't let me change the path from the subfolder to the mainfolder. The logo was missing for example.

    The URL is http://der-tut-nichts.info/

  6. Ypanesa
    Member
    Posted 3 months ago #

    Ok, it as activated one again. You see? Nothing changed. Click on Startseite (not the logo)

  7. WPyogi
    Volunteer Moderator
    Posted 3 months ago #

    So you moved the site? Is that what you are saying the problem is from? In that case, did you follow?

    http://codex.wordpress.org/Moving_WordPress

  8. Ypanesa
    Member
    Posted 3 months ago #

    How lucky I am. I did everything like described, exept... I forgot the menu. So I try again with the child theme.

  9. Ypanesa
    Member
    Posted 3 months ago #

    OK, it is the child theme that's missing something. What files will I need fot the child? I changed some title sizes and added a text-indent for the h1 title. I did that in the WP backend, but I prefere a child theme.
    So now I made a new folder in the themes folder and I uploaded a style.css and a picture for the child theme. And I get the error again.

  10. WPyogi
    Volunteer Moderator
    Posted 3 months ago #

    What is in the child theme style.css file? (It should not be a copy of the parent theme).

  11. Ypanesa
    Member
    Posted 3 months ago #

    /*
    Theme Name: Customizr Child
    Theme URI: http://der-tut-nichts.info/
    Description: Child Theme for the Customizr Theme
    Author: Ingrid Libicky
    Author URI: http://der-tut-nichts.info/
    Template: Customizr
    Version: 1.0
    */

    THIS IS NEW - JUST TRYING BUT IT DOES NOT WORK
    /* Import the style.css of the customizr base theme */
    @import url('../customizr/style.css');

    h1 {
    font-size: 38px;
    line-height: 38px;
    }
    h2 {
    font-size: 20px;
    margin-top: 1.5em;
    }

    h3 {
    font-size: 17px;
    margin-top: 1.5em;
    }

    h1.entry-title {
    text-indent: -61px;
    padding-left: 61px;
    }

    .by-author {
    display: none;
    }

    /* Not working */
    .navbar .nav {
    font-family: Karla, Arial;
    }

  12. Andrew Nevins
    Spam zapper & Volunteer Moderator
    Posted 3 months ago #

    Are you sure you should be using a capital C in the "Template:" ?

  13. Ypanesa
    Member
    Posted 3 months ago #

    Oh holy.... does that matter? mpfff....

  14. WPyogi
    Volunteer Moderator
    Posted 3 months ago #

    Yes, it matters greatly :)!

  15. Ypanesa
    Member
    Posted 3 months ago #

    Yeah! Why did that work local on my computer but not on the server? Such a silly mistake!

    Do I need to import the style sheet of the base theme?

    And the last one: How can I format the subtitle (upper right)? You see the last entry in my css. It's not working and I don't have any other idea.

  16. WPyogi
    Volunteer Moderator
    Posted 3 months ago #

    Can you activate the child theme? Did you add that font?

  17. Ypanesa
    Member
    Posted 3 months ago #

    It's not working. The child style.css is in the folder customizr-hund. I deleted the css ind the themes editor (backend) and the formatting is missing. You can see that here, where the text-indent should work on the h1. http://der-tut-nichts.info/wp-admin/customize.php

  18. Andrew Nevins
    Spam zapper & Volunteer Moderator
    Posted 3 months ago #

    Are you enqueing your fonts anywhere? Or using something like a fonts plugin? You can't just reference your font like this:

    /* Not working */
    .navbar .nav {
    font-family: Karla, Arial;
    }
  19. WPyogi
    Volunteer Moderator
    Posted 3 months ago #

    I can't see anything in your Dashboard. But I do not see a child theme active on your site.

  20. Ypanesa
    Member
    Posted 3 months ago #

    Ah, I see. I think I don't use a child theme. It is to complicated for me. When I activate the child, the menues are missing. I have no clue to fix that and I don't want to invest more time.

    I use google fonts. I just activated the plugin. I should not tell you, how long I am already working on this site. So the font for the subtitle is already a long term question. ;)

  21. WPyogi
    Volunteer Moderator
    Posted 3 months ago #

    When I activate the child, the menues are missing.

    Yes, theme options and settings don't carry over to a child theme - but you should be able to just reselect your menus under the menu screen.

    If you need help with the font, I'd suggest posting a new thread on the theme's own forum since that's not the topic of this thread -

    http://wordpress.org/support/theme/customizr#postform

  22. Ypanesa
    Member
    Posted 3 months ago #

    Thank you so much for you help!

Reply

You must log in to post.

About this Topic